WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#22646 closed defect (bug) (fixed)

Remove Title field from Edit Image modal

Reported by: ryan Owned by: ryan
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: has-patch
Focuses: Cc:

Description

Since the title attribute was removed from img tags in #18984, the Title field should be removed from the Edit Image modal and should no longer be inserted in the img tag. This modal should contain only those fields specific to the display of the image within the context of a post. Since Title is now the attachment page title and only the attachment page title, it is global rather than post specific and can removed from Edit Image.

Attachments (1)

22646.diff (1.6 KB) - added by nacin 3 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 follow-up: @nacin3 years ago

The problem is that "Title" is used for non-images. But those shouldn't have captions. (The original idea is that "Describe this image..." would be captions for images, title for other files.)

We tried to get down to one field this release (though alt was a stretch), and now we're back up to 3, and WP.com is up to 4 again because the Carousel feature (for reasons unknown to me) use titles and descriptions but not captions.

Ideally there is an interior edit window come 3.6 or 3.7 that allows for image editing and also editing of fields we hide here. Not sure what to do here for 3.5. Do we throw in the towel?

comment:2 @ryan3 years ago

Throw in the towel? Maybe.

Let's go ahead and remove the insertion of the title attribute while we debate the UI.

comment:3 in reply to: ↑ 1 @koopersmith3 years ago

Replying to nacin:

The problem is that "Title" is used for non-images.

I'm confused. What does this have to do with the Edit Image modal? I thought this was in refrence to the old wpeditimage modal, which only edits images (by design).

comment:4 follow-up: @ryan3 years ago

I'm talking about: click an image inside the editor, click on the edit image icon, Edit Image modal.

comment:5 in reply to: ↑ 4 @nacin3 years ago

  • Keywords has-patch added
  • Summary changed from Remove Title field from Edit Media modal to Remove Title field from Edit Image modal

Replying to ryan:

I'm talking about: click an image inside the editor, click on the edit image icon, Edit Image modal.

Got it. Need sleep. Renaming the ticket.

Let's move title to "Advanced" and move Alt to below caption?

@nacin3 years ago

comment:6 @ryan3 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In 22942:

In the edit image modal, move Title to the advanced section and move Caption above Alt.

Props nacin
fixes #22646

Note: See TracTickets for help on using tickets.