WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 4 years ago

#22648 closed defect (bug) (fixed)

No error reporting for failed upload of background image in theme customizer

Reported by: WPsites Owned by:
Milestone: 4.1 Priority: normal
Severity: normal Version: 3.4
Component: Customize Keywords:
Focuses: Cc:

Description

I tried uploading a background image using the theme cusomizer in 3.5 RC2 but nothing happened. After a few more tries I worked out that there was a problem uploading the file but WordPress didn't inform me of this, which it should.

It was only once I'd looked at the response from async-upload.php that I realised there even was a problem.

filename: "Screen Shot 2012-11-28 at 17.50.55.png"
message: "Unable to create directory wp-content/uploads/2012/11. Is its parent directory writable by the server?"
success: false

Attachments (1)

error.png (15.9 KB) - added by ocean90 6 years ago.

Download all attachments as: .zip

Change History (12)

#2 @WPsites
6 years ago

Yes looks like it is related to that. I searched through Trac before posting this but couldn't find anything!

@ocean90
6 years ago

#3 follow-up: @ocean90
6 years ago

https://core.trac.wordpress.org/raw-attachment/ticket/22648/error.png

You don't get this message?

Yes, it's sad that there isn't currently an informative message.

#4 in reply to: ↑ 3 @koopersmith
6 years ago

Replying to ocean90:

You don't get this message?

Yes, it's sad that there isn't currently an informative message.

This ticket is referring to the customizer, not media (but yes, you're correct).

While this is not so great, it is also not a regression.

#5 @nacin
6 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release
  • Version changed from trunk to 3.4

Since we don't have any error handling in the customizer at all yet, we need to punt on this.

Separately, informative messages are now fixed in trunk, for media. Woo.

#6 @helen
5 years ago

#23288 was marked as a duplicate.

#7 @unsalkorkmaz
5 years ago

  • Cc unsalkorkmaz@… added

#8 @tw2113
5 years ago

This is going to be true on any file upload using customizer, not just background images. Would be awesome get this bumped up and taken care of to help users avoid confusion, especially if we're trying to encourage developers to use this instead of options pages.

#9 @SergeyBiryukov
5 years ago

  • Component changed from Media to Appearance

#10 @ocean90
4 years ago

Related: #22148

#11 @ocean90
4 years ago

  • Keywords needs-patch removed
  • Milestone changed from Future Release to 4.1
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [30309].

Note: See TracTickets for help on using tickets.