WordPress.org

Make WordPress Core

Opened 6 years ago

Last modified 6 weeks ago

#22660 reopened defect (bug)

Admin bar in multisite: mobile tap on "My Sites" dropdown in back-end doesn't work

Reported by: devinreams Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 3.4.2
Component: Toolbar Keywords: needs-patch bulk-reopened
Focuses: multisite Cc:

Description

Quick steps here to reproduce an issue where the "My Sites" dropdown (multisite networks) will drop down and show the "Network Admin" link and the list of your sites. But, clicking on a site (to expand and see "Dashboard", "New Post", etc.) does not happen. Tapping the blog name just closes the dropdown.

I'm not sure what's different but I can consistently reproduce this when in the admin back-end (but works OK on front-end admin bar when viewing a site):

From /wp-admin/ on a mobile device (tested on iOS 6, iPhone 5, iPad) with a multisite network:

  1. Tap "My Sites" in admin bar
  2. See "Network Admin" and list of sites below
  3. Tap one one of the site names

Expected: Site name expands to show "Dashboard", "New Post", etc. (same behavior as front-end when viewing site). Screenshot: http://d.pr/i/reOi

Actual: Tapping site name simply closes the "My Sites" dropdown, does not browse anywhere nor expand menu

Change History (11)

#1 @Ipstenu
6 years ago

I can reproduce this too.

I have script debug on, by the way.

#2 @devinreams
6 years ago

  • Component changed from General to Toolbar

Yeah I get it with or without script debug.

I poked around in admin-bar.js, wondered if hoverIntent had anything to do with it (as its not loaded on front-end) and ruled that out.

My ability to troubleshoot further is a bit limited from here.

#3 @nacin
6 years ago

Related? #22505

#4 @devinreams
6 years ago

Ah yes, looks like it is.

I did some quick JS profiling in case it helps someone much better at this than I.

FRONT END (works as expected, jQuery not loaded)

Using Twenty Twelve, without jQuery loaded, I only get three events to go from tapping "My Sites" to tapping the name of a site because admin-bar.js comes in: http://d.pr/i/2Mhu

Tap "My Sites":

  • mouseover admin-bar.js 298

Then tap "{Blog Name}":

  • mouseout admin-bar.js 302
  • mouseover admin-bar.js 298

BACK END (does not work, jQuery loaded)

With jQuery loaded in the back-end we get a mess of additional events: http://d.pr/i/MltG

Tap "My Sites":

  • touchstart jquery.js 2
  • touchstart jquery.js 2
  • mouseover jquery.js 2
  • mousemove jquery.js 2
  • click jquery.js 2

... etc.

#5 @nacin
6 years ago

  • Version changed from trunk to 3.4.2

Not a regression, so not for 3.5. If this is a duplicate of #22505 (not sure re: frontend versus backend etc.), can someone close it?

#8 @jeremyfelt
4 years ago

  • Focuses multisite added

#9 @iseulde
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This ticket has not seen any activity in over *two* years, so I'm closing it as "wontfix".

The ticket may lack decisiveness, may have become irrelevant, or may not have gathered enough interest.

If you think this ticket does deserve some attention again, feel free to reopen.

For bugs, it would be great if you could provide updated steps to reproduce against the latest version of WordPress (5.0.2 at the time of writing). Remember images or a video can be superior to explain a problem. At the very least, quickly test again to make sure the bug still exists.

If it’s an enhancement or feature, some extra motivation may help.

Thank you for your contributions to WordPress! <3

#10 @JeffPaul
3 months ago

  • Keywords bulk-reopened added
  • Milestone set to Awaiting Review
  • Resolution wontfix deleted
  • Status changed from closed to reopened

A decision was made to reopen tickets that were closed in the bulk edit that this ticket was affected by. This ticket is being placed back into the Awaiting Review milestone so it can be individually evaluated and verified to determine if it is still relevant/valid or reproducible.

#11 @cbutlerjr
6 weeks ago

  • Keywords changed from needs-patch, bulk-reopened to needs-patch bulk-reopened

Is this still an issue? If not, this ticket can/should be closed.

Note: See TracTickets for help on using tickets.