WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22675 closed feature request (duplicate)

Detach from Auto Draft

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Media Library currently offers the "Attach" option for images that had been added via the Upload New Media page.

However, there is no "Attach" or "Detach" available for images that had been added via QuickPress or the post editor.

Consider that if you had uploaded a number of images and they got stuck to an "Auto Draft" object, if you later go and insert those images into a new post and publish it, the images remain attached to the Auto Draft. Further, if those images were inserted with the "Attachment Page" link setting, then the site will throw 404 errors when those images are clicked.

The only way I can imagine an end user working around this problem is to then remove the images from the post and upload duplicate image copies using one of the methods that doesn't generate Auto Drafts.

Change History (2)

comment:1 SergeyBiryukov17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6820.

comment:2 SergeyBiryukov17 months ago

  • Component changed from General to Media
Note: See TracTickets for help on using tickets.