WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22677 closed defect (bug) (invalid)

3.4.2 Upgrade Kills all thumbnails in media and site

Reported by: mikenytola Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Database Keywords: reporter-feedback
Focuses: Cc:

Description

After updating Wordpress to 3.4.2 all thumbnail images are no longer appearing on the site as well as inside of admin > media, and is showing the default.png file instead of the proper thumbnail.

Also if you try to edit image you get "Image data does not exist. Please re-upload the image."

I have tried:

  1. All plugins have been deactivated and the problem still occurs.
  2. Reinstalling Wordpress 3.4.2 does not fix the problem.
  3. Changing themes does not fix the problem. No matter what the theme is this problem occurs.
  4. Happens on both PC and Mac and all browsers.

Change History (6)

comment:1 mikenytola17 months ago

  • Cc mikenytola@… added
  • Severity changed from normal to major

comment:2 dd3217 months ago

From which version did you upgrade from?

comment:3 SergeyBiryukov17 months ago

  • Component changed from General to Media
  • Keywords reporter-feedback added

comment:4 Ipstenu17 months ago

I'm inclined to say this should go to the support forums. 3.4.2 has been running in the wild for a while, and this is the first (non Multisite) time I've seen this. Every time I have, it's been a wild server config with wonky PHP that needed upgrading.

comment:5 nacin17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

comment:6 mikenytola17 months ago

  • Component changed from Media to Database
  • Severity changed from major to normal

I had already searched the support forums and stackoverflow and everywhere else. I finally got access to the clients database the next day where I found the problem was with a corrupted table (wp_postmeta). Simple repair fixed it. I'm not sure if the upgrade was the cause or not since I got pulled into this bug repair a couple weeks after the upgrade.

Note: See TracTickets for help on using tickets.