WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 8 months ago

Last modified 8 months ago

#22682 closed defect (bug) (fixed)

Close Button Breaks in Customizer After Refresh

Reported by: miqrogroove Owned by: helen
Milestone: 3.7 Priority: low
Severity: minor Version: 3.5
Component: Accessibility Keywords: has-patch
Focuses: Cc:

Description

Steps to reproduce (keyboard only):

  1. Open the theme customizer.
  2. Tab past the top buttons.
  3. Press F5.
  4. Now try to use the Close or Cancel button.

Expected result: Should be able to Close or Cancel.

Actual result: The button can still be clicked, but it is broken for keyboard usage.

Found in 3.5-RC2-22961 using Chrome 23 and WinXP.

Attachments (2)

22682.diff (436 bytes) - added by lessbloat 17 months ago.
22682.1.diff (410 bytes) - added by lessbloat 8 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 miqrogroove17 months ago

Workaround: Tab away from buttons and press Alt + Left several times to return to the Themes page.

Last edited 17 months ago by miqrogroove (previous) (diff)

comment:2 nacin17 months ago

Is this reproducible in 3.4.2?

comment:3 miqrogroove17 months ago

I assumed this was a new accessibility feature of 3.5?

I couldn't figure out how to get to the customizer by keyboard in 3.4.2. I can action the customizer link, but focus moves to the preview pane and no amount of tabs seems to get me to the customizer controls.

comment:4 miqrogroove17 months ago

  • Severity changed from normal to minor

Reducing severity as it seems unlikely the user would need to refresh the page.

lessbloat17 months ago

comment:5 lessbloat17 months ago

22682.diff​ forces the redirect - fixing the issue. Before this, if you edited a field and closed without saving, then went back into the customizer, all of your changes were lost anyway - so it doesn't look as though we're losing anything by forcing a redirect all of the time. Koopersmith may think differently. :-)

comment:6 follow-up: miqrogroove17 months ago

22682.diff​ isn't testing well for me. If I use the keyboard to navigate to the Customizer, hit Enter on the close button, and then try to go back to the Customizer by keyboard, it wont load. I can't reproduce that problem by mouse, and the problem goes away when I remove the patch or disable script debug.

comment:7 in reply to: ↑ 6 lessbloat17 months ago

Replying to miqrogroove:

22682.diff​ isn't testing well for me. If I use the keyboard to navigate to the Customizer, hit Enter on the close button, and then try to go back to the Customizer by keyboard, it wont load. I can't reproduce that problem by mouse, and the problem goes away when I remove the patch or disable script debug.

Yep, good catch. I was able to replicate what you're seeing. This is a weird little bug.

comment:8 nacin17 months ago

  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low

lessbloat8 months ago

comment:9 lessbloat8 months ago

  • Keywords has-patch added

22682.1.diff​ should fix this.

comment:10 helen8 months ago

  • Owner set to helen
  • Resolution set to fixed
  • Status changed from new to closed

In 25027:

Make sure the close button in the Customizer still works after a refresh. props lessbloat. fixes #22682.

comment:11 helen8 months ago

  • Milestone changed from Future Release to 3.7
Note: See TracTickets for help on using tickets.