WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#22706 closed defect (bug) (duplicate)

Preview not working correctly when Wordpress is not installed in same directory

Reported by: frizzle Owned by:
Milestone: Priority: normal
Severity: major Version: 3.4.2
Component: General Keywords:
Focuses: Cc:

Description

I recently installed Wordpress into a different directory. So the page is accessed by going to http://mypages.com/ but the WP installation is in http://mypages.com/wp/

I did this using the exact instructions here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

The site is not MultiSite.

It works perfectly EXCEPT when it comes to previewing posts. If I preview a unpublished, draft post, it tries to access http://mypages.com/?p=114&preview=true — which doesn't work.

The only funny thing about this install (which is brand-new) the different directory. (The same theme, files, version, etc. work fine on a testing server where Wordpress is installed in the same directory.)

I also have trouble previewing changes — I get this form of URL for pages and this form for posts:

http://mypages.com/2012/12/03/post-title/?preview=true&preview_id=65&preview_nonce=41dd6ae5b9

http://mypages.com/page-title/?preview=true&preview_id=43&preview_nonce=35c393cf95

For both I get the following response: "You do not have permission to preview drafts."

Again, the only thing different between this install and another, cloned install is the ability to have Wordpress in its own directory. I suspect the same sort of bug is at the heart of both.

Not having the ability to preview posts or changes is a "major" bug in my book — it's pretty key for all of us who don't want to fly blind!

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13779. Going to reopen that ticket.

Note: See TracTickets for help on using tickets.