Make WordPress Core

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#22715 closed defect (bug) (fixed)

No items found message in new media modal

Reported by: tomthewebmaster's profile tomthewebmaster Owned by: nacin's profile nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: has-patch commit
Focuses: Cc:

Description

When I was working in the new media modal, I discovered what seems to be an unintended message. To reproduce:

  • Click on an uploaded image
  • Press "Edit"
  • Press "Clear"

I received the message shown in the attached image, indicating "No items found." and an opportunity to upload new images. It doesn't seem one should be presented with a message to upload images in the "Media Library" area. It would be better if the user were returned to the media library.

Attachments (2)

22715.png (83.3 KB) - added by tomthewebmaster 12 years ago.
22715.diff (492 bytes) - added by koopersmith 12 years ago.

Download all attachments as: .zip

Change History (15)

#1 @tomthewebmaster
12 years ago

  • Summary changed from No items found message in Media Modal to No items found message in new media modal

#2 @tomthewebmaster
12 years ago

  • Component changed from General to Media

#3 @nacin
12 years ago

  • Version set to trunk

#4 @lessbloat
12 years ago

Note: you're no longer able to see/click the edit button if you only have a single image selected. Nor can you any longer see the clear link when in bulk edit. However, you can replicate this by selecting multiple images, clicking edit, then clicking the "X" on each of the images.

@koopersmith
12 years ago

#5 @koopersmith
12 years ago

  • Keywords has-patch commit added

Returns the user to the library when the editing a selection and no items are selected (as intended).

#6 @tomthewebmaster
12 years ago

I applied 22715.diff​ and am returned to Upload Files, not the Media Library.

#7 follow-up: @nacin
12 years ago

Testing with SCRIPT_DEBUG on?

#8 in reply to: ↑ 7 @tomthewebmaster
12 years ago

Replying to nacin:

Testing with SCRIPT_DEBUG on?

Yes.

#9 @tomthewebmaster
12 years ago

I applied the patch for #22718 (along with this patch (22715.diff​)), and now this is working correctly for me, too. I am now being returned to the Media Library. Not sure what was going on.

#10 @lessbloat
12 years ago

+1 to 22715.diff​. Works for me.

#11 @nacin
12 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 23051:

Media: Return to the library when the editing a selection and all items get de-selected. props koopersmith. fixes #22715.

#12 @SergeyBiryukov
12 years ago

  • Milestone changed from Awaiting Review to 3.5

#13 @nacin
11 years ago

Resulted in #22930.

Note: See TracTickets for help on using tickets.