WordPress.org

Make WordPress Core

#22717 closed defect (bug) (fixed)

When deleting an image with the delete or backspace keys, the popup buttons aren't hidden

Reported by: azaozz Owned by: ryan
Milestone: 3.5 Priority: low
Severity: minor Version: 3.5
Component: TinyMCE Keywords: has-patch
Focuses: Cc:

Description

As the title. We used to hide the buttons on a timeout in 3.4 so this wasn't noticeable.

Attachments (2)

22717.patch (591 bytes) - added by azaozz 17 months ago.
22717.2.patch (589 bytes) - added by lessbloat 17 months ago.

Download all attachments as: .zip

Change History (7)

azaozz17 months ago

comment:1 azaozz17 months ago

  • Milestone changed from Awaiting Review to 3.5

Was having some slowdown concerns about adding another listener to keydown but this seems quite fast.

lessbloat17 months ago

comment:2 lessbloat17 months ago

One tiny fix in 22717.2.patch (ed wasn't being passed in). Tested both removal of single images, and galleries.

Version 0, edited 17 months ago by lessbloat (next)

comment:3 nacin17 months ago

  • Keywords has-patch added

comment:4 bobbravo217 months ago

  • Cc bob@… added

tested 22717.2 and can confirm the patch works as intended and doesn't have any side effects.

Manually tested the TinyMCE manipulation from the console using: tinyMCE.editors[0].plugins.wordpress._hideButtons();

comment:5 ryan17 months ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In 23046:

When deleting an image in the editor with the delete or backspace keys, hide the edit and delete popup buttons.

Props azaozz, lessbloat
fixes #22717

Note: See TracTickets for help on using tickets.