WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22721 closed defect (bug) (fixed)

Non-image file selected in Gallery view + disappearing URL

Reported by: pavelevap Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords: has-patch needs-testing
Focuses: Cc:

Description

1) Non-image file still selected in Gallery view

Media modal, click Insert media, see details about any non-image file. Click Create gallery, selected non-image file is still selected and I can add images to it.

2) URL disappears after selecting None

Media modal, click Insert media, select any image, set "Link To" to "None". Change "Link To" to "Media File", but URL is not visible now.

Attachments (2)

Missing_URL.jpg (28.6 KB) - added by pavelevap 17 months ago.
22721.diff (380 bytes) - added by helenyhou 17 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 in reply to: ↑ description miqrogroove17 months ago

Replying to pavelevap:

1) Non-image file still selected in Gallery view

Confirmed, although that file wont show up after clicking Create a new gallery. This will also happen if you upload a non-image file to the Create Gallery tab instead of the Insert Media tab rather than switching after upload.

2) URL disappears after selecting None

I could not reproduce that.

comment:2 pavelevap17 months ago

Ad 2) Screenshot added

pavelevap17 months ago

comment:3 koopersmith17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

1) Fixed in [23045] see #22718.

2) I cannot reproduce this either. We've fixed a bunch of issues there today, so I'm going mark this as fixed. Please open a new ticket if there are any issues.

comment:4 SergeyBiryukov17 months ago

  • Milestone changed from Awaiting Review to 3.5

comment:5 pavelevap17 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ad 1) No, it was not fixed. I can still reproduce it in trunk.

Ad 2) It will be probably browser related issue. It works well for example in IE9, but problem can be reproduced in Chrome.

comment:6 SergeyBiryukov17 months ago

2) URL disappears after selecting None

Could not reproduce in Firefox 17 or Chrome 23.

comment:7 pavelevap17 months ago

Ad 2) Thank you for testing, Sergey. Now I found, that it is also somehow related to localized version. English works well, but current Czech is the cause of problem in Chrome. Maybe some longer strings?

helenyhou17 months ago

comment:8 helenyhou17 months ago

  • Keywords has-patch needs-testing added

I think the key is that the input is being set to display: block within a label that's not display: block (div.setting label rather than label.setting here). SergeyBiryukov helpfully noted:

If "Attachment Page" translation is longer than 22 characters, that triggers it for me. Looks like dropdown width somehow interferes with it.

I think 22721.diff should fix it. I did not note any visual side effects, but of course would like extra eyes.

comment:9 SergeyBiryukov17 months ago

Tested 22721.diff, looks good.

comment:10 nacin17 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from reopened to closed

In 23063:

Media: Sidebar labels should be display block. Prevents wonkiness like inputs disappearing because Chrome no like you. props helenyhou. fixes #22721.

comment:11 nacin17 months ago

Part 1 is a duplicate of #22725. [23063] fixes part 2.

comment:12 pavelevap17 months ago

Awesome, part 2 is fixed! I noticed you had funny times with Czech in IRC :-) Thank you!

Note: See TracTickets for help on using tickets.