WordPress.org

Make WordPress Core

#22727 closed defect (bug) (invalid)

Reverse the order of the images doesn't work (3.5)

Reported by: Bichareh Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Gallery Keywords: reporter-feedback
Focuses: Cc:

Description

I have 2 Problems with the gallery.

  1. I can’t reverse the order of the images. I can see the new order in the backend, but when I publish the gallery nothing changed.
  2. I always upload an extra pictures as featured image. It is not showing in the backend of the gallery but when I publish it, its in the gallery of my website and I can’t remove it.

Change History (6)

comment:1 Bichareh17 months ago

  • Component changed from General to Gallery
  • Summary changed from Reverse the order of the images doesn't work to Reverse the order of the images doesn't work (3.5)
  • Version set to trunk

comment:2 nacin17 months ago

Hello, we're going to need some more information. What is actually in your post content? If it is only [gallery], then you didn't complete the final step of actually updating the gallery for the editor. In that case, no amount of ordering would work for you.

Anything you can provide of what you did would be great.

comment:3 Bichareh17 months ago

No, it looks like that: [gallery ids="113411,113416,113413,113412,113414,113415,113417,113418"]

I simply create a gallery. But I use this plugin http://wordpress.org/extend/plugins/gallery-extended/ to show my gallerys. I don't know where the problem is.

Example for a gallery on my site: http://www.promicabana.de/nikki-reed-halb-marathon-las-vegas/nikki-reed-las-vegas-marathon/

comment:4 nacin17 months ago

From reading the description, the Gallery Extended plugin no longer makes much sense under this newer paradigm, as you can create multiple galleries with individual images. That is why the IDs are stored directly in the shortcode, to allow for explicit grouping and ordering.

If you receive [gallery ids="113411,113416,113413,113412,113414,113415,113417,113418"] but then proceed to use a different plugin to show your gallery based on other settings, it isn't going to work.

comment:5 scribu17 months ago

  • Keywords reporter-feedback added

Please try deactivating the Gallery Extended plugin and let us know if you experience either of the 2 problems you mentioned.

comment:6 markjaquith17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

It's a problem with the plugin. It does not support 'include', 'exclude', or 'ids'. It'll need an update.

Note: See TracTickets for help on using tickets.