WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#22728 closed defect (bug) (fixed)

Insert Media 404 for wpspin_light.gif on subfolder installation

Reported by: n7studios Owned by: nacin
Milestone: 3.5 Priority: normal
Severity: trivial Version: 3.5
Component: Media Keywords: needs-testing close
Focuses: Cc:

Description

Using WordPress 3.5 RC3, my Google Chrome Console reports a 404 error for http://127.0.0.1/wp-admin/images/wpspin_light.gif.

However, my site is installed in a sub directory at http://127.0.0.1/dev

To reproduce:

  1. Ensure your browser's console is open to view issues / errors
  2. Create or edit a Page
  3. Click on the Add Media button
  4. Click on the Media Library 'tab' (to the right of Upload Files, below the Insert Media title)
  5. Click on an image
  6. Console says:

GET http://127.0.0.1/wp-admin/images/wpspin_light.gif 404 (Not Found) - load-scripts.php:2

Visiting http://127.0.0.1/dev/wp-admin/images/wpspin_light.gif displays the image as expected.

Change History (7)

comment:1 nacin17 months ago

  • Version set to trunk
.media-sidebar .settings-save-status .spinner {
	background: url(../../wp-admin/images/wpspin_light.gif) no-repeat;

Yeah, we can't do that.

comment:2 helenyhou17 months ago

  • Milestone changed from Awaiting Review to 3.5

Rawr. Let's copy wpspin_light.gif over include wp-includes/images. And maybe just name it wpspin there, because dark doesn't exist anymore, anyway.

Version 0, edited 17 months ago by helenyhou (next)

comment:3 nacin17 months ago

In 23023:

Copy wpspin_light to wp-includes as wpspin.gif. Use it in media views. see #22728.

comment:4 nacin17 months ago

  • Keywords needs-testing close added

Can someone verify this on a retina device?

comment:5 nacin17 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 23026:

Move HiDPI block to the bottom of media-views. @media does not provide additional specificity, so the non-retina stuff overrides if the retina rules come first. props lessbloat, fixes #22728.

comment:6 TobiasBg17 months ago

I don't get it. Why is it necessary to copy the image? "wp-includes" and "wp-admin" are in the same level, even in subfolder installs, aren't they? Am I missing something?

comment:7 helenyhou17 months ago

We should never be guessing at paths - this bites us every so often. Folders can be moved if so desired, etc.

Note: See TracTickets for help on using tickets.