WordPress.org

Make WordPress Core

#22732 closed defect (bug) (fixed)

Media in IE: Upload dialog still pop ups even when you're in library view

Reported by: ocean90 Owned by: nacin
Milestone: 3.5 Priority: low
Severity: normal Version: 3.5
Component: Media Keywords: needs-testing has-patch
Focuses: Cc:

Description

  • Open the media modal
  • Have in mind where the Select Button is
  • Switch to the library view
  • Click near the place where the button was before
  • Upload dialog pop ups :(

Can anyone else confirm this behavior as well?

Attachments (14)

22732.media-library-ie7.png (65.2 KB) - added by SergeyBiryukov 17 months ago.
22732.diff (971 bytes) - added by lessbloat 17 months ago.
22732.media-library-ie7.2.png (38.5 KB) - added by SergeyBiryukov 17 months ago.
22732.media-library-ie8.png (63.4 KB) - added by SergeyBiryukov 17 months ago.
22732.2.diff (1.7 KB) - added by lessbloat 17 months ago.
22732.from-url-ie7.png (32.2 KB) - added by SergeyBiryukov 17 months ago.
22732.3.diff (2.3 KB) - added by lessbloat 17 months ago.
22732.4.diff (2.3 KB) - added by lessbloat 17 months ago.
22732.upload.diff (1.1 KB) - added by koopersmith 17 months ago.
22732.upload.2.diff (1.9 KB) - added by koopersmith 17 months ago.
22732.upload.3.diff (2.3 KB) - added by koopersmith 17 months ago.
22732.upload.4.diff (2.3 KB) - added by koopersmith 17 months ago.
22732-5.patch (2.3 KB) - added by azaozz 17 months ago.
22732-6.patch (2.4 KB) - added by lessbloat 17 months ago.

Download all attachments as: .zip

Change History (41)

comment:1 georgestephanis17 months ago

Comfirmed in IE9.

Also when you right click there, you get a 'sliverlight' dialog. Methinks it may be an issue of silverlight overlaying something and it not getting stashed.

Version 0, edited 17 months ago by georgestephanis (next)

comment:2 SergeyBiryukov17 months ago

Confirmed in IE 7 and 8. I don't have Silverlight installed, so I get a Flash menu on right click.

Moreover, Media Library doesn't seem to work at all in IE 7. The media modal content is blank: 22732.media-library-ie7.png. Works fine in IE 8 though.

comment:3 lessbloat17 months ago

Hmm... I can't seem to be able to replicate this in IE7 or IE8.

I can however verify that the media library is showing a blank screen in IE7.

comment:4 ocean9017 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.5

1, 2, 3… FIGHT.

comment:5 SergeyBiryukov17 months ago

Also, opening the media modal and closing it with no changes leads to "Are you sure you want to leave this page" warning when pressing F5 or trying to go to another screen in both IE 7 and 8.

comment:6 follow-up: ocean9017 months ago

IE 7 and 8: From URL - When pasting an image URL into the field nothing happens.

lessbloat17 months ago

comment:7 lessbloat17 months ago

22732.diff​ is a quick stab at getting us mostly back on course with IE7 media library.

comment:8 in reply to: ↑ 6 lessbloat17 months ago

Replying to ocean90:

IE 7 and 8: From URL - When pasting an image URL into the field nothing happens.

It appears to work for me in both.

comment:9 azaozz17 months ago

Perhaps we should add an .ie7 class to the modal like we do for #wpadminbar? That would avoid the css hacks.

comment:10 follow-up: SergeyBiryukov17 months ago

22732.diff appears to fix the Media Library in IE 7.

However, thumbnails are much larger in IE 7 (only 3 columns vs. 7 columns in IE 8), see 22732.media-library-ie7.2.png and 22732.media-library-ie8.png. Not sure if that's intentional.

lessbloat17 months ago

comment:11 in reply to: ↑ 10 lessbloat17 months ago

Replying to SergeyBiryukov:

However, thumbnails are much larger in IE 7

IE7 doesn't appear to be auto-resizing the sizes based on the width of the browser. 22732.2.diff​ changes the default width/height from 199px/199px to 120px/120px.

comment:13 follow-up: SergeyBiryukov17 months ago

"From URL" looks weird in IE 7: 22732.from-url-ie7.png. Aside from scrollbars, "Upload Files" and "Media Library" tabs should not be there.

lessbloat17 months ago

comment:14 lessbloat17 months ago

Replying to azaozz:

Perhaps we should add an .ie7 class to the modal like we do for #wpadminbar? That would avoid the css hacks.

Done in 22732.3.diff.

lessbloat17 months ago

comment:15 in reply to: ↑ 13 lessbloat17 months ago

Replying to SergeyBiryukov:

"From URL" looks weird in IE 7: 22732.from-url-ie7.png. Aside from scrollbars, "Upload Files" and "Media Library" tabs should not be there.

Scroll bars and margin should be fixed in 22732.4.diff​. I'm not seeing the "Upload Files" and "Media Library" tabs. Here's what I see:

http://f.cl.ly/items/2Z08022S0t0L0v3m1J2J/from-url.jpg

koopersmith17 months ago

comment:16 koopersmith17 months ago

  • Keywords has-patch added; needs-patch removed

Tested the uploading bug fairly thoroughly in IE8. attachment:22732.upload.2.diff fixes it for me.

comment:17 koopersmith17 months ago

Turns out that while the shim doesn't open the modal, the overlay is still there. How fun.

comment:18 koopersmith17 months ago

Tested with IE8, using the HTML4, Silverlight and Flash runtimes.

comment:19 ocean9017 months ago

Tested with IE9, using the HTML4 and Silverlight runtimes.

comment:20 koopersmith17 months ago

  • Keywords commit added

Commit attachment:22732.upload.4.diff — leave open and lower priority for the IE7 fixes.

comment:21 nacin17 months ago

  • Keywords dev-reviewed added

comment:22 koopersmith17 months ago

In 23053:

Toggle display of plupload overlays when the select files button is hidden. see #22732.

comment:23 koopersmith17 months ago

  • Keywords commit dev-reviewed removed
  • Priority changed from normal to low

azaozz17 months ago

comment:24 azaozz17 months ago

22732-5.patch is similar to 22732.4.diff​ but has alternative layout fix for IE7. Both patches add smaller default size for the thumbnails for IE7 relying on the resizing JS not working there.

lessbloat17 months ago

comment:25 lessbloat17 months ago

Two minor tweaks in 22732-6.patch:

  • Added 4px margin-top to "From URL" text box
  • Added align: left to .link-to-custom which shows up under the "Link to" drop down.

Other than that, 22732-5.patch​ looks great.

Last edited 17 months ago by lessbloat (previous) (diff)

comment:26 azaozz17 months ago

22732-6.patch​ looks good here too, +1 to commit.

comment:27 nacin17 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 23061:

Media IE7 fixes. props azaozz, lessbloat. fixes #22732.

Note: See TracTickets for help on using tickets.