WordPress.org

Make WordPress Core

#22741 closed defect (bug) (fixed)

Minor positioning issue for gallery edit screen at small widths

Reported by: markjaquith Owned by: markjaquith
Milestone: 3.5 Priority: normal
Severity: minor Version: 3.5
Component: Media Keywords: has-patch needs-testing
Focuses: Cc:

Description

[Reverse order]Drag and drop to reorder images. (smushed together)

http://cl.ly/image/2P3l2U080V0j/Screen%20Shot%202012-12-04%20at%204.16.53%20PM.png

Attachments (4)

22741.patch (725 bytes) - added by SergeyBiryukov 17 months ago.
22741.2.patch (1.9 KB) - added by lessbloat 17 months ago.
22741.3.patch (884 bytes) - added by lessbloat 17 months ago.
22741.4.diff (1.6 KB) - added by koopersmith 17 months ago.

Download all attachments as: .zip

Change History (13)

SergeyBiryukov17 months ago

comment:1 SergeyBiryukov17 months ago

  • Keywords has-patch added

comment:2 follow-up: lessbloat17 months ago

22741.patch​ works fine until you get even smaller:

http://f.cl.ly/items/09250e2B2V1M2u3z0T2m/gallery-small.jpg

comment:3 in reply to: ↑ 2 SergeyBiryukov17 months ago

Replying to lessbloat:

22741.patch​ works fine until you get even smaller

Yeah, that currently happens without the patch as well. Appears to be caused by fixed height on .media-toolbar, not sure how to avoid that.

lessbloat17 months ago

comment:4 lessbloat17 months ago

22741.2.patch​ uses absolute positioning to ensure that the line never wraps when the screen is < 900px.

comment:5 helenyhou17 months ago

Are we okay with the button overlapping the text?

comment:6 lessbloat17 months ago

Koopersmith: I'm not coming up with much:

.narrow-width
.narrow-window
.hide-when-narrow

lessbloat17 months ago

comment:7 follow-up: lessbloat17 months ago

22741.3.patch just deals with the task at hand.

koopersmith17 months ago

comment:8 in reply to: ↑ 7 koopersmith17 months ago

  • Keywords needs-testing added

Replying to lessbloat:

22741.3.patch just deals with the task at hand.

Dealing with the task at hand sounds right to me. We can't break at the exact lengths of strings, because we need to account for internationalization. attachment:22741.4.diff attempts to break at smart points for the defaults and will automatically hide any elements if they do overflow the bar's limits.

comment:9 markjaquith17 months ago

  • Owner set to markjaquith
  • Resolution set to fixed
  • Status changed from new to closed

In 23071:

Better responsive breakpoints for the Gallery editing screen. props koopersmith. fixes #22741

Note: See TracTickets for help on using tickets.