WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#2276 closed defect (bug) (duplicate)

wp_upload_bits bad variable name

Reported by: Xas Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Administration Keywords: wp_upload_bits upload
Focuses: Cc:

Description

I'm using WP 2.0, stable version.
Trying to develop an xml-rpc software, I get some error about creating the file uploaded.

After some investigation, I found the upload directory was lost when creating the file.

To be more precise in the file functions-post.php, at line 897, you have :
$new_file = $uploadspath? . "/$filename";, but $uploads doesn't exist. It's $upload (without the 's') as declared line 887.
After correcting this, the upload works fine.

Change History (1)

comment:1 ryan8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2202

Note: See TracTickets for help on using tickets.