Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#22806 closed defect (bug) (duplicate)

Media uploader links images to wrong attachment pages

Reported by: jenia's profile jenia Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: Media Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

To reproduce:

  1. Start a new post, upload an image to it and save the post
  2. Start another new post, insert the old image into it as an attachment
  3. Publish the second post

Once you click on the image, it takes you to the attachment page related to the first post, and not the attachment page of the post where you inserted the image into. If you are logged out, you will probably get an error message.

(Tested using WordPress 3.5-RC3-23080)

Change History (4)

#1 @nacin
10 years ago

  • Version changed from trunk to 2.5

Yep. This is not a regression though. We've just made it easier to do. Note that this was doable with attachments for as long as they've been around. For an image in a gallery to not be attached to its post, that's new.

#3 @SergeyBiryukov
10 years ago

  • Description modified (diff)

#4 @nacin
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22829.

Note: See TracTickets for help on using tickets.