WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#22833 closed defect (bug) (duplicate)

Reordering of images doesn't work correctly (3.5 RC5)

Reported by: Bichareh Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Gallery Keywords:
Focuses: Cc:

Description

Hi,

the reordering of images in any gallery doesn't work as it should be.

I've sorted the images in my test gallery - the thumbnails in frontend are sorted correctly, but not the images in the actual gallery view.

Have a look at this and click through the images, there is a difference... http://dev.promicabana.de/?p=631

Change History (6)

comment:1 @dd323 years ago

I'm confused, how does this differ from your other ticket #22829?

comment:2 @Bichareh3 years ago

http://core.trac.wordpress.org/ticket/22829 - you can not add old images to a new gallery, otherwise it looks weird in the frontend.

This Ticket: Images can not be sorted correctly. Old or new images...it doesn't matter.

I don't think it's the same issue. Please correct me, if I'm wrong...

comment:3 @SergeyBiryukov3 years ago

Sounds like the same underlying issue (no context for adjacent_image_link()), just different manifestation.

#22829 is about Next/Previous navigation when combining attached and unattached (or attached to another post) images in one gallery.

This ticket is about Next/Previous navigation when the images are sorted differently in the gallery. So, not an exact duplicate, but related.

comment:4 @dd323 years ago

This ticket is about Next/Previous navigation when the images are sorted differently in the gallery.

Ah yes, I missed that.

It all comes back to the same issue, that next/previous are time-based on post_parent rather than the gallery the image is appearing in. So not a duplicate, but it's fate intertwined with #22829

comment:5 @helenyhou3 years ago

Put briefly, attachment pages are not equivalent to a gallery view unless you are using just a plain [gallery] shortcode.

We need to either close both this and #22829, or rename #22829 something like "Specified IDs for the gallery shortcode have no influence on adjacent_image_link() on attachment post pages, in which case it is a duplicate, because it's the same cause.

Version 0, edited 3 years ago by helenyhou (next)

comment:6 @nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22829.

Note: See TracTickets for help on using tickets.