WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#22848 closed enhancement (duplicate)

add tinyMCE to category and tag description

Reported by: zabatonni Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

clients often asks how to add hyperlink or bold text into category description.

simple solution is to edit core wp-admin/edit-tag.php
and replace line 65 with this code

<?php wp_editor(html_entity_decode($tag->description),'description',array('wpautop'=>true,'media_buttons'=>false,'quicktags'=>true,'textarea_rows'=>'15','textarea_name'=>'description')); ?>

but it's always getting back after updating

Attachments (1)

edit-tag-form.php (4.2 KB) - added by zabatonni 3 years ago.

Download all attachments as: .zip

Change History (2)

@zabatonni3 years ago

comment:1 @SergeyBiryukov3 years ago

  • Component changed from General to Administration
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20901.

Also, no need to hack the core file, there's a plugin for that:
http://wordpress.org/extend/plugins/rich-text-tags/

Note: See TracTickets for help on using tickets.