WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#22849 closed defect (bug) (fixed)

New Media Uploader doesn't error when an image is too big

Reported by: Ipstenu Owned by: markjaquith
Milestone: 3.5 Priority: normal
Severity: major Version: 3.5
Component: Media Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description

Source me on my iPhone, swearing.

Requirement: PHP file upload size set 'low' (2Megs)

Action: Upload large image (3megs)

Expected Outcome: Upload errors becuase you can't upload a file that big.

Actual Outcome: On existing media uploads, error out with 'Your file is too big, neener.' On new media, it hangs.

I don't think this is a blocker, but given that the iPhone makes images of over 2megs regularly and the default limit for a lot of hosts is 2, this should be in a point release or a hotfix.

Attachments (1)

22849.diff (522 bytes) - added by koopersmith 3 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 @scribu3 years ago

  • Milestone changed from Awaiting Review to 3.5.1

comment:2 @nacin3 years ago

  • Milestone changed from 3.5.1 to 3.5

comment:3 @nacin3 years ago

Cannot reproduce. Works for me in Mac Chrome 23 (stable), using the Plupload html5, flash, and html4 runtimes.

comment:4 @nacin3 years ago

IRC: https://irclogs.wordpress.org/chanlog.php?channel=wordpress-dev&day=2012-12-10&sort=asc#m515178

Ipstenu is able to get a hanging, dead-on-arrival attachment view when uploading multiple images.

comment:5 @markjaquith3 years ago

Uploading three images. One too large. Large one hangs:

http://f.cl.ly/items/2i2q2h3D1Y2y3j3o3M1e/Screen%20Shot%202012-12-10%20at%204.54.03%20PM.png

comment:6 @markjaquith3 years ago

Uploading single too-large image errors as expected:

http://f.cl.ly/items/132a2p2e0k0O0h3T2b1x/Screen%20Shot%202012-12-10%20at%204.45.14%20PM.png

comment:7 @markjaquith3 years ago

If all images are larger than the limit, I get an error for each. It's just the "some under the limit, some over the limit" situation that causes the hang.

@koopersmith3 years ago

comment:8 @koopersmith3 years ago

  • Keywords has-patch commit added

Plupload sends files that have failed to the FilesAdded event, so we need to ignore them.

comment:9 @nacin3 years ago

  • Keywords dev-reviewed added

comment:10 @markjaquith3 years ago

  • Owner set to markjaquith
  • Resolution set to fixed
  • Status changed from new to closed

In 23162:

Ignore failed uploads. props koopersmith. fixes #22849

comment:11 @nacin3 years ago

In 23165:

Ignore failed uploads. props koopersmith. fixes #22849. for the 3.5 branch.

Note: See TracTickets for help on using tickets.