WordPress.org

Make WordPress Core

#22870 closed defect (bug) (duplicate)

Add New Media Page doesn't fail out on large images

Reported by: Ipstenu Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

Discovered while debugging #22869 (which is why your steps to repro are similar)

To Reproduce: Upload https://objects.dreamhost.com/ipstenu-images/sunset_2_22_11_by_kenshinkyo-d3a6slk.jpeg to your WP install in the media-new.php page

Note: Image is 12600x9450 and 4.9MB

Expected Outcomes:

VPS/Dedicated with tons of memory: Success

Shared hosted without a lot of memory: Failure, not enough memory

Actual outcomes:

VPS as expected.

Shared

  • On 3.4.2: "Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 50400 bytes) in /home/blah/site.com/wp-includes/media.php on line 258" (good)
  • 3.5 new uploader correctly errors out with (good)
  • 3.5 media-new.php hangs on 'Crunching' (bad)

Obviously media-new.php hanging on crunching isn't desirable. That should error out.

Change History (1)

comment:1 SergeyBiryukov10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23127.

Note: See TracTickets for help on using tickets.