WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#22886 closed defect (bug) (duplicate)

Cannot use <tab> to go from Tags' input field to its Add button — at Version 3

Reported by: Daedalon Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Accessibility Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

In the edit post page under wp-admin there's the Tags widget with an input textfield, a submit button and a "Choose from the most used tags" textlink, in that particular order in both HTML and in the RTL reading order.

When the browser's focus is in the input textfield, as a user I expect that pressing the <tab> key moves the focus to the following item, the submit button, enabling the workflow of pressing <tab><space> to add a tag. In at least IE8 and any versions of Pale Moon / Firefox I've tried so far this isn't possible: the focus is moved to the textlink instead.

The technical reason for this is that the submit button has 'tabindex="3"'. Removing that tabindex solves the issue on Pale Moon / Firefox, but not knowing the reasons it was originally added, a different approach might be better.

Summary of issues:

  1. Fix the <tab> handling in the Tags widget in wp-admin edit post screen by either
    1.a. removing the 'tabindex="3"' from the submit button in the Tags wp-admin edit post widget,
    1.b. change the tabindex's value to be such that it works on the most used browsers, or
    1.c. fix the functionality in JavaScript.

Change History (3)

comment:1 @Daedalon3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This appears to be fixed in 3.5 and has thus affected only versions 3.4.2 and earlier.

comment:2 @helenyhou3 years ago

  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to worksforme

comment:3 @SergeyBiryukov3 years ago

  • Component changed from Taxonomy to Accessibility
  • Description modified (diff)
  • Resolution changed from worksforme to duplicate

Fixed in [21311]. Marking as a duplicate of #21340.

Note: See TracTickets for help on using tickets.