WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#22891 closed defect (bug) (invalid)

WordPress Filter media_buttons_context is Not Working in WP Version 3.5 — at Version 2

Reported by: onetarek Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I am using the filter 'media_buttons_context' to add my custom media button beside the media upload button in the post/page editor.
After updating wordPress to version 3.5 my button is not being shown.

My codes are bellow:

<?php
function wp_myplugin_media_button($context) {
	$wp_myplugin_media_button = ' %s' . '<a href="media-upload.php?type=upload&TB_iframe=true&tab=upload" class="thickbox"><img src="http://onetarek.com/wp-content/uploads/2012/12/shortcode_btn.png" width=15 height=15 /></a>';

	return sprintf($context, $wp_myplugin_media_button);
}

add_action('media_buttons_context', 'wp_myplugin_media_button');
?>

What is the main reason of this problem with wp 3.5?

Change History (2)

comment:1 helenyhou16 months ago

  • Keywords dev-feedback needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

media_buttons_context was meant for the text label, not adding buttons. You should be using media_buttons instead. See #22559

comment:2 SergeyBiryukov16 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.