WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 12 months ago

#22894 reopened enhancement

Need WordPress Media Uploader Stop or Cancel Button in WP Version 3.5

Reported by: onetarek Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: ui Cc:

Description

Today I was testing the new media uploader of WP 3.5 from post editor by clicking 'Add Media'. I clicked 'upload files' and I choose a big file from my computer by a mistake. But I did not want to upload that file. Then I wanted to cancel the uploading, but there is no stop or cancel button . Then I close the popup window and open again by clicking 'Add Media' button. I see the previous file is being uploaded yet. I choose another small file and both files upload are running.
http://onetarek.com/wp-content/uploads/2012/12/stop-media-uploader.jpg

Change History (11)

comment:1 @ocean902 years ago

  • Keywords ui-feedback added; needs-testing removed
  • Type changed from feature request to enhancement

comment:2 @SergeyBiryukov2 years ago

There's no way to cancel the currently uploading file from JS. See the discussion in #19050.

comment:3 @SergeyBiryukov2 years ago

Related/duplicate: #7634

comment:4 @SergeyBiryukov2 years ago

#24569 was marked as a duplicate.

comment:5 @mark-k2 years ago

Maybe just add a notification if it is a big upload. Something like "Uploading these file(s) will probably take more then a minute, are you sure you want to upload them?". Maybe use the hearbeat test to estimate the actual upload speed to make an educated guess.

comment:6 @ericlewis12 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is duplicate of #19050 as @SergeyBiryukov said earlier. The UI gives realtime progress on the upload, and if you upload by mistake you'll just have to delete the files after they're uploaded. By not offering UI to cancel the upload, we're implicitly telling users you can't cancel it, so I don't think more explicit detail needs to be stated that you can't cancel the upload.

Any follow-up discussion should go on #19050.

comment:7 @ericlewis12 months ago

  • Focuses ui added
  • Keywords ui-feedback removed

comment:8 @DrewAPicture12 months ago

  • Milestone Awaiting Review deleted

comment:9 @mark-k12 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Just because 3 years ago it wasn't possible doesn't mean that it should not be handled now. This is a real problem when you are uploading by mistake big files from metered or very slow connections.

Right now the only way to stop the upload is by closing the tab or browser, and both methods are not obvious (especially on smartphones/tablets) and not very user friendly.

comment:10 follow-up: @SergeyBiryukov12 months ago

  • Milestone set to Awaiting Review

#19050 was closed on a completed milestone, so it's OK to continue the discussion here.

However, I don't think anything has changed since then, we still use the same uploader.

comment:11 in reply to: ↑ 10 @mark-k12 months ago

Replying to SergeyBiryukov:

However, I don't think anything has changed since then, we still use the same uploader.

Totally possible that it is still impossible to cancel uploads,but even if it is impossible I think that some kind of alert should be issued if the network condition is not good enough to finish the upload in reasonable time. Even on desktops with a drag&drop interface it is too easy to start an upload of a huge file by mistake.

Note: See TracTickets for help on using tickets.