WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 16 months ago

Last modified 16 months ago

#22908 closed defect (bug) (worksforme)

Add Media button doesn't work when Visual Editor is disabled (3.5)

Reported by: onions Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.5
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

In my User Profile, I have the option "Disable the visual editor when writing" checked.

When writing a post, I am unable to add media with the "Add Media" button. Clicking on it does nothing.

I go back to my User Profile, and uncheck the visual editor setting to enable it.

I go back to writing a post. In visual mode, I can click on the "Add Media" button, and I am able to add media. I close the window and click on the code view tab of the editor. I click on the "Add Media" button and am still able to add media.

I go back to my User Profile and check the visual editor setting to disable it.

I go back to writing a post and cannot add media with the "Add Media" button.

I suppose I could keep the visual editor enabled and stay in code view all the time, but it's still a bug.

Change History (6)

comment:1 nacin17 months ago

  • Keywords reporter-feedback added; needs-patch removed

This works for me, and was something we tested rather extensively during 3.5's development.

Can you look for a JavaScript error in your console? http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

I would guess this is a plugin or theme conflict.

comment:2 ryansatterfield16 months ago

  • Cc r@… added

Nacin: I had the same issue as onions in FF 17.0.1, Chrome, and IE 9. I've also noticed complaints online about this. I will do more research in the morning to try and find where the issue is so I can submit a patch. I tried two different themes to see if maybe it was a theme issue. The themes I used were 2012 and 2010. I had all the plugins disabled. The media button does work if you right click and hit open in new tab. I'll keep you posted.

comment:3 ryansatterfield16 months ago

  • Keywords 2nd-opinion close added

Nacin and onions: I installed two dummy wordpress sites. One using PHP 5.3.xx and one using 5.4.8 This is not a bug, because it doesn't occur when WordPress is installed or updated properly. Without more information, I'd say this happens to sites when an auto-update doesn't finish or for some reason it is finished, but improperly.

Last edited 16 months ago by ryansatterfield (previous) (diff)

comment:4 ryansatterfield16 months ago

  • Keywords close removed

Out of the 3 installs only one had the same issue as Onions. After putting define('SCRIPT_DEBUG', true); in wp-config.php. the issues disappeared, but that doesn't fix the issue. I will read the debug.log when WordPress creates one. One has yet to appear.

Version 0, edited 16 months ago by ryansatterfield (next)

comment:5 ryansatterfield16 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

If the issues Onions experienced and the ones I experienced our the same, then this isn't a WordPress bug. If you ever had BulletProof plugin installed, then that's causing the issue. Delete the .htaccess in /wp-admin. I discovered this the hard way. There is a guide on the support forums http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

comment:6 SergeyBiryukov16 months ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.