WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 21 months ago

Last modified 21 months ago

#22916 closed enhancement (fixed)

Date/time format translations for front-end

Reported by: npetetin Owned by: nacin
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.5
Component: I18N Keywords:
Focuses: Cc:

Description

Hi.

Since the split of mo/po files between admin and front-end contexts, some resources that were useful for the front-end are now available only for admin. One of them is the date/time format: it's really great it's localized in the reading options panel, but the main purpose of the option remains the front-end and the way the dates and times are displayed, so we need the "translations" in the front-end po/mo files.

So the request is to switch the following strings from admin to general text domain:

  • F j, Y
  • g:i a
  • F j, Y g:i a

Thanks.

Change History (9)

comment:1 @toscho2 years ago

  • Cc info@… added

comment:2 @nacin2 years ago

  • Milestone changed from Awaiting Review to 3.6
  • Owner set to nacin
  • Status changed from new to assigned

comment:3 @adamsilverstein2 years ago

  • Cc ADAMSILVERSTEIN@… added

comment:4 @sabreuse2 years ago

  • Cc sabreuse added

comment:5 @knutsp2 years ago

  • Cc knut@… added

comment:6 @alex-ye2 years ago

  • Cc nashwan.doaqan@… added

comment:7 @markjaquith21 months ago

  • Milestone changed from 3.6 to Future Release

comment:8 @nacin21 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 24454:

Add some localized date/time strings to the main wordpress.pot. These strings appear in the admin only but can be leveraged outside of the admin by design. fixes #22916.

comment:9 @nacin21 months ago

  • Milestone changed from Future Release to 3.6
Note: See TracTickets for help on using tickets.