WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#22927 closed defect (bug) (invalid)

bloginfo( 'stylesheet_url' ) returns http instead of https, regression in 3.5

Reported by: sporhincak Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: General Keywords:
Focuses: Cc:

Description

After update to 3.5, bloginfo( 'stylesheet_url' ) returns link with http instead of https, which breaks https only sites with self signed cert.

Reproducible in clean install, with themes twentyeleven,twentytwelve, set page to https://domain.tld

Change History (3)

comment:1 follow-up: johnbillion16 months ago

  • Keywords reporter-feedback added

Unable to reproduce. get_bloginfo( 'stylesheet_url' ) correctly returns an SSL URL when on an SSL page. Have you tested with all plugins disabled?

comment:2 in reply to: ↑ 1 sporhincak16 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Replying to johnbillion:

Unable to reproduce. get_bloginfo( 'stylesheet_url' ) correctly returns an SSL URL when on an SSL page. Have you tested with all plugins disabled?

Yes, it was with all plugins disabled. Confusing, because with same nginx setup (reverse proxy ) and older version of wordpress, links for css were generated as they should be, https.

But after update there were only https links for rss feeds and comments, while css were http. Solved by moving from http to https on worker host and changed proxy_pass from http://worker; to https://worker; on reverse proxy.

Thanks

comment:3 SergeyBiryukov16 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Severity changed from major to normal
Note: See TracTickets for help on using tickets.