WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22953 closed defect (bug) (invalid)

Upgrade to Wordpress 3.5 Immediately Breaks Subdomain Multisite Network

Reported by: sffandom Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Multisite Keywords:
Focuses: Cc:

Description

There are numerous unresolved reports of subdomain networks failling to resolve the secondary sites (subdomains) after upgrading to Wordpress 3.5 in the Wordpress.Org forum. No one seems to be responding.

I upgraded a network yesterday. The primary site resolves fine but I get a DNS failure on a secondary site; until the upgrade this problem did not exist. We had Wordpress 3.4.2 installed prior to the upgrade. All plugins were up-to-date until the most recent wave of plugin updates (due to the release of Wordpress 3.5). The plugins were upgraded with the Wordpress.

No changes have been made to the .htaccess or wp-config.php file. No changes have been made to the server's DNS or wildcard subdomain configuration.

Another domain on the same hosting account, also configured for multisite using subdomains, continues to work fine. That domain has NOT been upgraded to Wordpress 3.5.

I am not a PHP developer and cannot recommend a fix. This issue needs immediate attention. I cannot make heads or tails of your ticket system.

Change History (10)

comment:1 follow-up: @dd322 years ago

for reference, the only forum thread I can see: http://wordpress.org/support/topic/wordpress-35-multisite-can-not-access-subsite-dashboards

The primary site resolves fine but I get a DNS failure on a secondary site; until the upgrade this problem did not exist.

Sounds like a server or domain configuration issue outside of WordPress, can you post a link to the site that works, and one that isn't?

I am not a PHP developer and cannot recommend a fix. This issue needs immediate attention. I cannot make heads or tails of your ticket system.

Trac is not a support avenue, WordPress is a open source system and the only "official" support is the forums and volunteers there, unless you hire a company who offers WordPress support.

comment:2 in reply to: ↑ description @rmccue2 years ago

Replying to sffandom:

I upgraded a network yesterday. The primary site resolves fine but I get a DNS failure on a secondary site; until the upgrade this problem did not exist. We had Wordpress 3.4.2 installed prior to the upgrade. All plugins were up-to-date until the most recent wave of plugin updates (due to the release of Wordpress 3.5). The plugins were upgraded with the Wordpress.

So, what you're saying is that DNS resolves for example.com, but not foo.example.com? Is the error in the DNS resolution or on the server side? (i.e. Does dig foo.example.com A fail? If so, that's a DNS issue, otherwise it might be a server issue)

comment:3 @sffandom2 years ago

There are at least three current discussions where the subdomain issue has been raised. So far it's being misdiagnosed as user installation error.

THIS IS NOT A CONFIGURATION ISSUE. I have a multisite network on the SAME SERVER that works just fine. It was NOT upgraded to Wordpress 3.5. The network that stopped working only did so as a direct result of the upgrade to Wordpress 3.5 with absolutely no changes to any configuration on the Website or server by me or my staff.

To answer the last question, we can get to www.example.com but NOT to blog.example.com (which was working just fine before upgrading the Wordpress from 3.4.2. to 3.5).

The wildcard subdomain is still configured properly in the table (alongside the properly configured wildcard subdomain for the other network that is still working).

comment:4 @sffandom2 years ago

I have started a new thread in the support forum here:
http://wordpress.org/support/topic/wordpress-35-breaks-subdomains-for-multisite-networks?

Hopefully others will share information.

To date I see discussions where people cannot get the subdomains to work on new installations (they are posting proper information), where the dashboards don't appear, and where the subdomains are not working as expected.

comment:5 in reply to: ↑ 1 @sffandom2 years ago

Replying to dd32:

for reference, the only forum thread I can see: http://wordpress.org/support/topic/wordpress-35-multisite-can-not-access-subsite-dashboards

The primary site resolves fine but I get a DNS failure on a secondary site; until the upgrade this problem did not exist.

Sounds like a server or domain configuration issue outside of WordPress, can you post a link to the site that works, and one that isn't?

Site that works: http://www.reflectivedynamics.com/

Site that no longer works: http://blog.reflectivedynamics.com/

I am not a PHP developer and cannot recommend a fix. This issue needs immediate attention. I cannot make heads or tails of your ticket system.

Trac is not a support avenue, WordPress is a open source system and the only "official" support is the forums and volunteers there, unless you hire a company who offers WordPress support.

I appreciate the clarification. But I'm not going to hire a developer since this issue appears to affect a lot of people. There are also complaints on Twitter, for what it's worth.

comment:6 follow-up: @dd322 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Site that works: ​http://www.reflectivedynamics.com/
Site that no longer works: ​http://blog.reflectivedynamics.com/

The DNS records for 'blog.reflectivedynamics.com' are missing, the domain doesn't point anywhere.
You can verify it yourself on the command line:

> ping reflectivedynamics.com
PING reflectivedynamics.com (66.79.188.10): 56 data bytes
64 bytes from 66.79.188.10: icmp_seq=0 ttl=53 time=191.880 ms

> ping blog.reflectivedynamics.com
ping: cannot resolve blog.reflectivedynamics.com: Unknown host

Not a WordPress problem, nor could it have been caused by WordPress. Contact your web host (Grey Web Host by the look of it?) to get them to set the DNS up again.

comment:7 in reply to: ↑ 6 ; follow-up: @sffandom2 years ago

Replying to dd32:

Site that works: ​http://www.reflectivedynamics.com/
Site that no longer works: ​http://blog.reflectivedynamics.com/

The DNS records for 'blog.reflectivedynamics.com' are missing, the domain doesn't point anywhere.

Dude, there were NEVER any DNS records for blog.reflectivedynamics.com. It's a multisite installation. It uses a WildCard subdomain.

You can verify it yourself on the command line:

> ping reflectivedynamics.com
PING reflectivedynamics.com (66.79.188.10): 56 data bytes
64 bytes from 66.79.188.10: icmp_seq=0 ttl=53 time=191.880 ms

> ping blog.reflectivedynamics.com
ping: cannot resolve blog.reflectivedynamics.com: Unknown host

Not a WordPress problem, nor could it have been caused by WordPress. Contact your web host (Grey Web Host by the look of it?) to get them to set the DNS up again.

IS there someone else who understands this better?

comment:8 @sffandom2 years ago

Okay, I have upgraded two other less critical networks, each on different hosting services. Both upgrades went through okay.

I will contact Grey Webhost and see what they have to say.

This ticket can be closed.

comment:9 in reply to: ↑ 7 @SergeyBiryukov2 years ago

  • Keywords needs-patch removed
  • Severity changed from blocker to normal

Replying to sffandom:

Dude, there were NEVER any DNS records for blog.reflectivedynamics.com. It's a multisite installation. It uses a WildCard subdomain.

Wildcard subdomain is also a DNS record, and it appears to have stopped working in your case for some reason. WordPress has no access to DNS records.

comment:10 @sffandom2 years ago

You were right, and I was wrong. It turns out that even though I could see the Wildcard subdomain record in my cPanel that data had dropped from the hosting provider's DNS table. They just went in, deleted my Wildcard and recreated it.

I apologize for the stink.

Note: See TracTickets for help on using tickets.