WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#22962 closed defect (bug) (duplicate)

Image thumbnail doesn't refresh after editing

Reported by: beerpulse Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

In the new media manager in 3.5, after editing an image's thumbnail, one would expect the 'refresh' button to re-load the thumbnail with the applied edits but the same un-edited image thumbnail reloads leaving it unknown whether the edits were applied. Not until you exit Media Manager & go to re-edit the same photo, do you see that your original changes were applied.

Steps to reproduce:

1) Click 'Add New Media' in Post Editor

2) Click any image in Media Manager

3) Click 'Edit Image'

[new tab opens with image editor]

4) Select a portion of the image to crop.

5) Select the 'Thumbnail' button under 'Apply changes to'

6) Click the crop button

7) Click save underneath the newly-cropped image.

8) Click update.

9) Click back to media manager tab

10) Click 'refresh' underneath image thumbnail.

[Newly-cropped thumbnail does not appear]

11) Click off of the media manager to exit.

12) Click 'Add New Media' again

13) Click same image

14) Click 'Edit image'

[image editor tab loads showing updated thumbnail with previous changes]

Those changes should appear at step 10.

This may be of normal severity but I've marked as major because it adds additional steps to updating a thumbnail than what was required in 3.4. I do a ton of thumbnail-editing so I'm admittedly biased.

Change History (7)

#1 @beerpulse
5 years ago

  • Component changed from General to Media

#2 @AdamCapriola
5 years ago

I'd like to add to this that I also lose my Medium and Large image sizes after performing the Thumbnail crop (in addition to the bug described above). All that becomes selectable for inserting into a post are the Full Size and new Thumbnail.

Prior to 3.5 the other sizes would remain and only the Thumbnail was changed.

#3 @markoheijnen
5 years ago

  • Keywords close added; needs-testing removed
  • Severity changed from major to normal

The image in the editor isn't the thumbnail size but the original size but scaled down. So the main issue of this ticket is invalid.

Also I can't reproduce the issue of Adam. I changed the image and what I see is that there is a new thumbnail image and the old one also still exists. I checked this on my drive. If you still have this issue you should create a new ticket with a full description with hosting or server configuration added.

#4 @beerpulse
5 years ago

I'm so used to cropping to the middle of the image that I didn't initially realize that the gallery of images from which to choose shows Wordpress' cropped thumbnail. Those thumbs makes for a prettier experience though from a user experience standpoint, it is more important for a publisher to see on the backend what the user is going to see on the frontend. And the current thumbnail function in Wordpress is going to show my hard-crop and not Wordpress' magic crop. I suppose I will re-file as an enhancement.

#5 @markoheijnen
5 years ago

Well the backend can't know what will be showed on the frontend. In your experience it is the thumbnail but there are a lot of examples it showed a medium image or a custom image size. Not sure if there is a filter to change which image will be showed.

Also it shows the original image without crop.

#6 @beerpulse
5 years ago

Just created ticket. Not sure if it clears things up.

http://core.trac.wordpress.org/ticket/22966

#7 @markoheijnen
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22966.

Note: See TracTickets for help on using tickets.