WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#22973 closed enhancement (duplicate)

Add meaningful class names to tables on the user profile edit page

Reported by: keenbeen Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

Users have been, since time immemmorial, using various hacks to hide unnecessary profile fields from the profile edit page. This usually involves unreliable methods such as hiding a table row with jQuery, by counting its index.

Different blocks on the profile edit page are already grouped into tables. Simply adding meaningfull class names to the tables would give reliable and direct access to them via CSS and Javascript, and save a lot of pain to those who need to selectively hide certain fields.

Attachments (1)

user-edit.diff (1.7 KB) - added by keenbeen 2 years ago.
Patch to wp-admin/user-edit.php

Download all attachments as: .zip

Change History (3)

@keenbeen2 years ago

Patch to wp-admin/user-edit.php

comment:1 @keenbeen2 years ago

  • Summary changed from Add meaningful classnames to tables on the user profile edit page to Add meaningful class names to tables on the user profile edit page

comment:2 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 3.5

Duplicate of #12295.

Note: See TracTickets for help on using tickets.