Make WordPress Core

Opened 11 years ago

Closed 9 years ago

#22974 closed defect (bug) (wontfix)

Media manager inaccessible when dragging several images on Safari

Reported by: mario-siteground's profile mario-siteground Owned by: azaozz's profile azaozz
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: External Libraries Keywords: has-patch reporter-feedback
Focuses: Cc:

Description

Browser: Version 6.0.2 (8536.26.17)

Target: The new media manager

Bug Description: After drag and dropping multiple images on the manager for upload, the manager becomes inaccessible.

Reason: In some cases the uploader-window fails to change display:block to display:none which makes everything on that page unclickable:

<div class="uploader-window" style="display: block; opacity: 0; "> <div class="uploader-window-content"> <h3>Drop files to upload</h3> </div> </div>

Since this is an external jQuery plugin used in Core and related to html5 structure, attached is the fix in the minified versions, as well as a standalone dev new version and the related code itself.

Attachments (4)

plupload.html5.dev.js (40.7 KB) - added by mario-siteground 11 years ago.
dev version created
plupload.html5.js (16.5 KB) - added by mario-siteground 11 years ago.
min patched
plupload.safari.patch (76.0 KB) - added by mario-siteground 11 years ago.
standalone bug
22974.diff (960 bytes) - added by nacin 11 years ago.

Download all attachments as: .zip

Change History (20)

@mario-siteground
11 years ago

dev version created

@mario-siteground
11 years ago

min patched

@mario-siteground
11 years ago

standalone bug

#1 @mario-siteground
11 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
11 years ago

  • Component changed from Media to External Libraries
  • Version changed from trunk to 3.5

Looking at plupload.safari.patch, this looks like something that should be fixed upstream.

#4 @nacin
11 years ago

  • Milestone changed from Awaiting Review to 3.5.1

@nacin
11 years ago

#5 @nacin
11 years ago

I created a patch based on https://github.com/moxiecode/plupload/tree/1.x. Can you explain your changes?

#6 follow-up: @nacin
11 years ago

And, is this applicable to Safari for Windows only?

#7 @nacin
11 years ago

  • Owner set to azaozz
  • Status changed from new to assigned

#8 in reply to: ↑ 6 @MattyRob
11 years ago

Replying to nacin:

And, is this applicable to Safari for Windows only?

I haven't seen this issue with Safari on OSX but what makes this strange is version 6.0.2 is the current release on OSX but it seems that version 5.1.7 is the current release of Safari on Windows (http://en.wikipedia.org/wiki/Safari_version_history). Maybe we need some reporter feedback.

#9 @SergeyBiryukov
11 years ago

  • Keywords reporter-feedback added

#10 @azaozz
11 years ago

Seems to be happening only on Safari/Windows, confirmed in 5.1.5. Can't reproduce in Safari/Mac 6.0.2.

Generally Plupload has always had some problems in Safari/Windows. The good news is that Plupload 2 is coming out soon-ish and will probably be in 3.6.

Not sure if we should patch plupload.html5.js. 22974.diff doesn't make any difference in Safari/Mac (obvious, as it runs only on Windows). In Safari/Windows 5.1.5 the patch prevents drag-drop completely (nothing happens after dropping files), without the patch drag-drop doesn't work (the first image is displayed in the browser).

Think best is to leave this for 3.6 when we will update to Plupload 2.

#11 @azaozz
11 years ago

  • Milestone changed from 3.5.1 to 3.6

#12 @ryan
11 years ago

  • Milestone changed from 3.6 to Future Release

#13 @tivnet
10 years ago

Checked today with Safari 5.1.7, Windows 8.1, WordPress 3.8.1 - did not notice any problems.

#14 @kovshenin
10 years ago

Can't reproduce this issue specifically, but probably related: #27341

#15 @helen
9 years ago

Is this still an issue?

#16 @azaozz
9 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

No, Safari/Windows was discontinued years ago. Don't see a point in trying to fix this.

Note: See TracTickets for help on using tickets.