WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#22982 closed defect (bug) (duplicate)

Problem with SSL when using the media library

Reported by: TedFolkman Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

Hello, Wordpress!

I hope I am doing this right--I am not a technical person, but someone who is a technical person at the support forum suggested that I "open a new ticket."

I am having an issue with WP 3.5 that I did not have with WP 3.4.2. I do all my site administration over SSL (my wp-config file has the following line: define('FORCE_SSL_ADMIN', true);). When I go to the dashboard I see the green padlock in the address bar, so I know my SSL certificate is working properly. With WP 3.5., when I go to my media library, instead of the green padlock I get a message saying that while my connection is encrypted, the page "includes other resources that are not secure" and that can be viewed by others while in transit or modified by an attacker. From looking at the html, it seems that the media file themselves are the culprit: the links to them are "http:" instead of "https:" If I click once on the button to take me back to the dashboard, I can navigate back to the dashboard, but the warning remains. But if I click on the dashboard button again, the green padlock returns.

In case it is useful, I use the following theme: WooThemes Canvas v. 5.0.13, and the following plugins:

Acronyms 2
Antispam Bee
BackWPup
Broken Link Checker
BulletProof Security
Liveblog
Login Lockdown
NextScripts: Social Networks Auto-Poster
Prevent Password Resetn
Quick Page/Post Redirect Plugin
Simple Footnotes
WordPress SEO
Wysija Newsletters

But I have found the same issue with all plugins deactivated.

Thank you!

Change History (2)

comment:1 johnbillion16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi Ted, welcome to WordPress Trac! Thanks for your well written and detailed bug report.

I'm closing your ticket as a duplicate of #15928 which addresses the technical reason behind non-SSL content showing up in the Media Library. You can subscribe to that ticket if you wish by adding your username or email address in the "Cc" field there.

comment:2 TedFolkman16 months ago

Thanks John! I have added my name as a cc to the other ticket.

Note: See TracTickets for help on using tickets.