WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#22983 closed defect (bug) (duplicate)

"All sizes except thumbnail" save does not work

Reported by: worldwisewebs Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

To reproduce:

  1. upload a new image, click the edit label
  2. click edit image button
  3. perform a crop on the image
  4. Under "Thumbnail settings", "Apply changes to" select "All sizes except thumbnail"
  5. Click save button underneath image crop

Bugs:

  • thumbnail will have proportions of the crop made, despite the setting
  • click edit image again, the Thumbnail Settings box is now gone.
  • Clicking restore original image restores image but thumbnail settings box remains missing

Screenshot of edit page without thumbnail settings box: http://www.diigo.com/item/image/23e4l/vud8

Change History (7)

comment:1 worldwisewebs16 months ago

  • Cc worldwisewebs@… added

comment:2 lewismcarey16 months ago

I had this until I realised that 'Crop thumbnail to exact dimensions (normally thumbnails are proportional)' was not checked in media settings screen.

comment:3 markoheijnen16 months ago

This seems as a server issue. Can you put here the server configuration or the host you are using.

comment:4 SergeyBiryukov16 months ago

  • Keywords reporter-feedback added

comment:5 worldwisewebs16 months ago

  • Keywords needs-testing added; reporter-feedback removed

This happens regardless of the "crop thumbnail to exact dimensions" setting. I had it on, but have confirmed with it off as well. I've tried this on two servers now, one with a local provider that we use:

Linux vhosts2.main.nc.us 2.6.32-5-686-bigmem
PHP Version 5.3.3-7+squeeze14
MySQL 5.1.66

Also on bluehost:
Linux box545.bluehost.com 2.6.32-20120131.55.1.bh6.x86_64
PHP Version 5.2.17
MySQL 5.5.28

Same results on both sites. Both sites are testing with no plugins active and the 2012 theme active. These are both test sites so I can provide logins if needed.

(Note: removed urls from original post since they won't be necessary.)

Last edited 16 months ago by worldwisewebs (previous) (diff)

comment:6 markoheijnen16 months ago

  • Keywords needs-patch added; needs-testing removed
  • Milestone changed from Awaiting Review to 3.5.1

Confirmed this and it's a bug caused in 3.5

comment:7 markoheijnen16 months ago

  • Keywords needs-patch removed
  • Milestone 3.5.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

After playing it's the same issue as #22985. Closing this one since that ticket shows what the issue is.

Note: See TracTickets for help on using tickets.