WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 4 weeks ago

#22986 closed defect (bug) (duplicate)

WP uses header image's GUID as URL

Reported by: bersbers Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Appearance Keywords: has-patch needs-testing
Focuses: Cc:

Description (last modified by SergeyBiryukov)

See summary. If I move my site (old domain becoming inaccessible), I cannot use my header images any more since
a) I am not allowed to change GUIDs.
b) GUIDs are used as URLs for header images:

http://core.trac.wordpress.org/browser/trunk/wp-includes/theme.php

1008        foreach ( (array) $headers as $header ) {
1009	                $url = esc_url_raw( $header->guid );

Attachments (1)

22986.patch (515 bytes) - added by toscho 16 months ago.
Use wp_get_attachment_image_src() for URL

Download all attachments as: .zip

Change History (8)

comment:1 bersbers16 months ago

I am not sure, but it seems that event newly uploaded files receive a GUID that contains the OLD domain. This means I cannot even re-upload header images, I cannot use any header image after moving a WordPress site. Can this be true?
(Probably not true generally. It does however seem true when I simply re-select the old header images from the media library. So I really need to re-upload ALL header images after moving the site?)

Last edited 16 months ago by bersbers (previous) (diff)

comment:2 SergeyBiryukov16 months ago

  • Description modified (diff)

comment:3 toscho16 months ago

  • Cc info@… added

toscho16 months ago

Use wp_get_attachment_image_src() for URL

comment:4 toscho16 months ago

  • Keywords has-patch needs-testing added

Not sure about the size argument. Is there a registered size for header images I missed?

comment:5 DH-Shredder3 months ago

  • Milestone changed from Awaiting Review to Future Release

comment:6 nacin2 months ago

  • Component changed from Themes to Appearance

comment:7 SergeyBiryukov4 weeks ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27222.

Note: See TracTickets for help on using tickets.