WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 8 weeks ago

#22990 closed enhancement (duplicate)

Edit custom image sizes

Reported by: jonkristian Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

There is currently no way to edit custom image sizes.

Since it's possible to create custom image sizes, it should also be possible to edit them in the backend.

Right now there three scenarios:

  1. All images
  2. All images except thumbnail
  3. Thumbnails only

Whatever choice you make it will affect all custom image sizes.

I propose more options added here,for instance:

  1. All images
  2. Custom -> Select size from select menu
  3. Thumbnails only

Attachments (5)

bird-thumbnail.jpg (35.9 KB) - added by anatolbroder 19 months ago.
Bird, thumbnail
bird-large.jpg (241.1 KB) - added by anatolbroder 19 months ago.
Bird, large
bird-medium-480x320.jpg (30.9 KB) - added by anatolbroder 19 months ago.
Bird, medium, mdpi
bird-medium-720x480.jpg (61.5 KB) - added by anatolbroder 19 months ago.
Bird, medium, hdpi
bird-medium-960x640.jpg (101.1 KB) - added by anatolbroder 19 months ago.
Bird, medium, xhdpi

Download all attachments as: .zip

Change History (11)

comment:1 helen19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19889.

anatolbroder19 months ago

Bird, thumbnail

anatolbroder19 months ago

Bird, large

anatolbroder19 months ago

Bird, medium, mdpi

anatolbroder19 months ago

Bird, medium, hdpi

anatolbroder19 months ago

Bird, medium, xhdpi

comment:2 SergeyBiryukov19 months ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

I don't think this is a duplicate of #19889.

#19889 describes a bug that causes custom image sizes to be removed from metadata when saving the edited image.

This ticket suggests an enhancement allowing to select which size the changes should be applied to.

comment:3 SergeyBiryukov18 months ago

#23274 was marked as a duplicate.

comment:5 helen11 months ago

#17956 was marked as a duplicate.

comment:6 SergeyBiryukov8 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

#28277 has a patch.

Note: See TracTickets for help on using tickets.