Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#23005 closed defect (bug) (duplicate)

wp_update_user breaks if ID not set

Reported by: actionnerd Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Users Keywords:
Focuses: Cc:


Passing an array of userdata to wp_update_user (first_name, last_name, user_email, user_login).

If ID is not in the array, then a PHP Fatal Error is triggered:
[19-Dec-2012 15:03:16 UTC] PHP Fatal error: Call to a member function to_array() on a non-object in ../web/content/wp-includes/user.php on line 1456

The codex for wp_update_user (http://codex.wordpress.org/Function_Reference/wp_update_user) does state "If $userdata does not contain an 'ID' key, then a new user will be created and the new user's ID will be returned.", which makes me think this might be a new bug.

Change History (3)

comment:2 @tyxla9 months ago

Related: #31097

comment:3 @SergeyBiryukov9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22858. Fixed in [23210] and [24345].

Note: See TracTickets for help on using tickets.