WordPress.org

Make WordPress Core

#23007 closed defect (bug) (invalid)

jQuery errors

Reported by: gwendydd Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: External Libraries Keywords:
Focuses: Cc:

Description

I'm developing a site here:
http://ally2.alchemycs.com

On the home page, in the middle where it says "Screenings", there is a box that uses jScrollPane (a jQuery plugin) to make the scrollbars look pretty. In 3.4.2, this worked just fine. When I updated to 3.5, this broke. I verified this by restoring the site in 3.4.2 from a backup, and upgrading again. The only thing I changed was the WP version, and it broke the scrollbar.

I think that the scrollbar is the visible symptom of a larger problem. In 3.5, I get this JS error message:
Error: Permission denied to access property 'toString'

This error message is caused by the embedded Vimeo video. If I take that out, I get a new error message:
Error: Syntax error, unrecognized expression: [type="text/javascript"],not([type])

That message is caused by modernizr.js, so if I disable that, I get a new error message:
Error: Syntax error, unrecognized expression: [type="text/javascript"],not([type])

It says that this error occurs in line 2 of jquery.min.js, which is being served by Google, so I know it doesn't have errors in it.

Disabling all plugins doesn't solve the problem. Obviously if I switch themes the problem goes away, because the default themes don't use the same jQuery plugins that I'm using. But again, the only difference between the functioning site and the non-functioning site was the version of WordPress.

Here's a conversation I had on the support forums about this:
http://wordpress.org/support/topic/35-causing-major-jquery-and-javascript-errors?replies=9

Change History (1)

comment:1 markoheijnen16 months ago

  • Component changed from General to External Libraries
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This isn't something that is wrong with WordPress core. It's because of the upgrade of jQuery what breaks jScrollPane plugin. What is basically the mistake of jScrollPane.

See http://stackoverflow.com/questions/11903758/jscrollpane-and-jquery-1-8-0

Note: See TracTickets for help on using tickets.