WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#23009 closed defect (bug) (duplicate)

Wrong type of image crop option

Reported by: anatolbroder Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.5
Component: Media Keywords: has-patch
Focuses: Cc:
PR Number:

Description

The image crop option must be a boolean. Now it returns a true value like

["crop"]=> string(1) "1"

or

["crop"]=> int(1)

It works, but it’s not nice. My patch transforms the return to a real boolean.

Attachments (1)

crop-bool.diff​ (883 bytes) - added by anatolbroder 7 years ago.
Set image crop option to boolean

Download all attachments as: .zip

Change History (3)

@anatolbroder
7 years ago

Set image crop option to boolean

#1 @anatolbroder
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23019.

#2 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Version changed from trunk to 3.5
Note: See TracTickets for help on using tickets.