WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

#23025 closed enhancement (fixed)

Review and update readme.html

Reported by: helen Owned by: helen
Milestone: 3.6 Priority: normal
Severity: normal Version:
Component: Help/About Keywords: dev-feedback needs-patch
Focuses: Cc:

Description

While this should likely be done more toward the middle or end of the cycle, let's not forget to take a good look at readme.html and its contents.

Attachments (6)

23025.patch (4.9 KB) - added by chrisrudzki 8 years ago.
23025-1.patch (5.5 KB) - added by chrisrudzki 8 years ago.
23025-2.patch (11.0 KB) - added by chrisrudzki 8 years ago.
23025-3.patch (11.0 KB) - added by chrisrudzki 8 years ago.
Changes in 23025-2.patch and Notepad++ suggestion
23025.2.patch (11.0 KB) - added by DrewAPicture 8 years ago.
23025.diff (3.6 KB) - added by nacin 8 years ago.

Download all attachments as: .zip

Change History (23)

#1 @nacin
8 years ago

Dropping the sections on XML-RPC, Post by Email, and User Roles seem sufficient.

#2 follow-up: @chrisrudzki
8 years ago

  • Cc chrisrudzki@… added
  • Keywords has-patch added
  • Removed XML-RPC, Post by Email, and User Roles sections

Other minor updates:

  • Replaced 'WordPad' reference with more common editors 'TextEdit' and 'Notepad'
  • Updated old reference to profile page -- from 'Profile' to 'Users -> My Profile'
  • Updated version to 3.6

@chrisrudzki
8 years ago

#3 @markoheijnen
8 years ago

Why dropping XML-RPC? Why not changing the text a bit by dropping only Atom Interface and adding the mobile apps to it

#4 @chrisrudzki
8 years ago

I think it's worth dropping XML-RPC as it's been enabled by default anyway, and it's probably worth moving toward a more accessible / less technical readme doc. I think adding some links to the mobile apps is a good idea.

I'm adding a couple more patches here:

  • 23025-1.patch includes the changes listed above, and also adds links to mobile apps
  • 23025-2.patch includes all the changes listed above, and others:
    • Removed links that are only useful after WordPress is installed
    • Replaced these with sample URLs, and menu references
    • Added 'Getting Started' section
    • Other minor changes

@chrisrudzki
8 years ago

@chrisrudzki
8 years ago

#5 in reply to: ↑ 2 ; follow-up: @SergeyBiryukov
8 years ago

Replying to chrisrudzki:

Replaced 'WordPad' reference with more common editors 'TextEdit' and 'Notepad'

Notepad++ might be a better suggestion for Windows. It handles Unix line breaks properly and saves PHP files without UTF-8 byte order mark (BOM) by default, which is crucial for international users.

Warning: Cannot modify header information - headers already sent by (output started at /home/user/site/public_html/wp-config.php:1) has been the top FAQ entry on ru.forums.wordpress.org for years now. The warning is caused by BOM after editing wp-config.php in the default Windows Notepad, so we specifically recommend against using it.

@chrisrudzki
8 years ago

Changes in 23025-2.patch and Notepad++ suggestion

#6 in reply to: ↑ 5 @chrisrudzki
8 years ago

Replying to SergeyBiryukov:

Notepad++ might be a better suggestion for Windows. It handles Unix line breaks properly and saves PHP files without UTF-8 byte order mark (BOM) by default, which is crucial for international users.

That's certainly good to know! TextEdit seems to save files without BOM by default, so it should be okay. I've updated the second version (23025-2.patch​) accordingly, which is the one I favor.

#7 @nacin
8 years ago

  • Component changed from Text Changes to Help/About

#8 @DrewAPicture
8 years ago

  • Cc xoodrew@… added

23025.2.patch:

  • adds a line about generating unique keys and salts
  • fixes the tone in several places
  • updates the URLs for the theme and plugin repositories as well as the mobile link

#9 @SergeyBiryukov
8 years ago

Is there a reason for changing the wp-admin links to plain text in 23025.2.patch?

#10 @SergeyBiryukov
8 years ago

Nevermind, the change actually comes from 23025-2.patch and is mentioned in comment:4.

@nacin
8 years ago

#11 @nacin
8 years ago

  • Keywords commit added

It's a bit too late now for major changes, as this file needs to be manually processed by translators.

23025.diff removes four outdated sections and fixes a single grammar issue. We can play with this more in 3.7.

#12 @nacin
8 years ago

In 24744:

Remove old, less relevant and in some cases obsolete readme sections. see #23025.

#13 @nacin
8 years ago

  • Milestone changed from 3.6 to Future Release

#14 @chriscct7
6 years ago

  • Keywords dev-feedback needs-patch added; has-patch commit removed
  • Milestone changed from Future Release to 4.4
  • Owner set to chriscct7
  • Status changed from new to assigned
  • Type changed from defect (bug) to enhancement

Continuing work in 4.4

#15 @chriscct7
6 years ago

  • Owner changed from chriscct7 to helen

This ticket was mentioned in Slack in #core by sergey. View the logs.


6 years ago

#17 @helen
6 years ago

  • Milestone changed from 4.4 to 3.6
  • Resolution set to fixed
  • Status changed from assigned to closed

Closing as fixed in 3.6. There's plenty that could be done, but let's open specific tickets for specific changes, and if an overhaul is done at some point, then we'll open a ticket for it then.

Note: See TracTickets for help on using tickets.