WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#23065 closed defect (bug) (fixed)

Post Becomes Unprotected (Password) Without Explicit Permission

Reported by: AKTed Owned by: SergeyBiryukov
Milestone: 3.6 Priority: normal
Severity: major Version: 2.7
Component: Editor Keywords: has-patch commit editorial-flow
Focuses: Cc:

Description

When you edit a post that's password protected and click 'Edit' next to 'Visibility: Password Protected', if you click 'Cancel' (still shows as 'Password Protected') then subsequently 'Update' it will change the visibility to 'Public'.

If you look closely, right after you click 'Cancel', while the section is collapsing, you'll see the password disappear. But it still says 'Visibility: Password Protected'.

Attachments (2)

patch_commit_1bf7f3273cb1.patch (773 bytes) - added by thomasvanderbeek 7 years ago.
Fixed #23065
patch_commit_f941f7f69a79.patch (2.2 KB) - added by thomasvanderbeek 7 years ago.
This patch is more consistent with the rest of the code conventions.

Download all attachments as: .zip

Change History (14)

#1 @miqrogroove
7 years ago

  • Component changed from General to Editor
  • Version changed from 3.5 to 3.4.2

Tested and confirmed in both 3.5 and 3.4.2.

#2 @thomasvanderbeek
7 years ago

  • Keywords has-patch added
  • Resolution set to fixed
  • Status changed from new to closed

#3 @SergeyBiryukov
7 years ago

  • Milestone changed from Awaiting Review to 3.6
  • Resolution fixed deleted
  • Status changed from closed to reopened

Tickets are marked as fixed when a change is made to the WordPress codebase which fixes the issue.

#4 @MikeHansenMe
7 years ago

  • Cc mdhansen@… added

Tested the patch on 3.6-alpha-23223. Fixes typo, correcting the problem.

#5 @nacin
7 years ago

  • Version changed from 3.4.2 to 2.8

I tracked this down to at least 2.8. hidden_post_password is the name, hidden-post-password appears to have always been the ID.

#6 @SergeyBiryukov
7 years ago

  • Keywords commit added
  • Version changed from 2.8 to 2.7

Introduced in [9639]. patch_commit_1bf7f3273cb1.patch looks proper.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

@thomasvanderbeek
7 years ago

This patch is more consistent with the rest of the code conventions.

#7 @kovshenin
7 years ago

  • Cc kovshenin added
  • Keywords editorial-flow added

#8 @ocean90
7 years ago

  • Cc ocean90 added

#9 @SergeyBiryukov
7 years ago

patch_commit_f941f7f69a79.patch would also require a change in CSS:
http://core.trac.wordpress.org/browser/tags/3.5/wp-admin/css/wp-admin.css#L3228

I guess it's better to leave post_password ID as is, for backwards compatibility reasons. A similar change was suggested for Dashboard in #17555.

patch_commit_1bf7f3273cb1.patch is enough to fix the issue.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#10 @SergeyBiryukov
7 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 23338:

Prevent an unintended visibility change from "Password protected" to "Public" when updating the post.

props thomasvanderbeek. fixes #23065.

#11 @SergeyBiryukov
7 years ago

#23633 was marked as a duplicate.

#12 @helen
7 years ago

#23633 was marked as a duplicate.

Note: See TracTickets for help on using tickets.