WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 15 months ago

Last modified 15 months ago

#23094 closed enhancement (wontfix)

Automatically assign post-format to posts

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Template Keywords:
Focuses: Cc:

Description

I played around with post-formats and decided that one of the annoying things with them is that you have to think what will be the best display format for what you write. IMO it is unneeded and can be automatically handled by wordpress, maybe with giving the user ability to override.

The way post formats are defined in the codex it should not be difficult to automate the decision, basically what we need is to set a number of words that should be included in the post to make it reguler post. Lets call this number N.

Asides are posts with less then N words and no media.

Links are posts with less then N words that have a valid URL as the title or one link in the text and doesn't have any media

Status is an Aside in a multi author site

Quote is a post which contains a blockquote + up to N words and no media

Image,Audio,Video,Gallery have a respective post type when there is only one media in the post and less then N additional words

Chat can be detected by the format in the text

Change History (6)

comment:1 SergeyBiryukov16 months ago

  • Component changed from I18N to Template

comment:2 obenland16 months ago

  • Cc obenland added

comment:3 follow-up: helen15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

"Up to N words" is not a good criterion. Everybody's posting style is different. This sounds interesting, but as a plugin.

comment:4 in reply to: ↑ 3 mark-k15 months ago

Replying to helen:

"Up to N words" is not a good criterion. Everybody's posting style is different. This sounds interesting, but as a plugin.

Extremely disagree. There are some trivial cases like a one image post or a one gallery post in which WordPress can assist the author in selecting the best fitting post format.

I know that 3.6 will have revamped UI for the post formats but this UI will not help people posting by email or through general purpose XML-RPC publishing software.

comment:5 helen15 months ago

Going to advise you to try it as a plugin first and see what feedback and adoption are like - in this case, it's better than a patch, as it will actually get real-world use. My instinct is that arbitrary criteria like word count is not something that lends itself to generalization in core.

comment:6 mark-k15 months ago

The problem is that I can predict the adoption of such a plugin will be 0. Right now in the repository there is only one plugin tagged as post-formats http://wordpress.org/extend/plugins/tags/post-formats which actually does anything non trivial with post formats http://wordpress.org/extend/plugins/automatic-featured-image-posts/ and even it has a default set to "no format".

It is an egg and chicken problem, since there are no themes doing anything interesting with the feature, there is no demand for the feature or enhancements to it, and since there is no demand, no theme author designs anything special for it.

I will call it a day on this. Maybe I will try to write a plugin if I will come up with a non trivial use case.

Note: See TracTickets for help on using tickets.