WordPress.org

Make WordPress Core

#23100 closed enhancement (duplicate)

Allow Custom Post Type Archives as Front Page in Reading Settings.

Reported by: drewcovi Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

As support for custom post types has matured, one really amazing feature that could use some consideration is the ability to select a custom post type archive as the homepage.

Currently, the only way to do this involves intercepting the query and forcing a search for the custom post type. Although this will ultimately pull from the correct archive template, there will be a discrepancy between the current page id and the selected front page id.

Change History (1)

comment:1 SergeyBiryukov16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19958.

Note: See TracTickets for help on using tickets.