WordPress.org

Make WordPress Core

#23105 closed enhancement (duplicate)

Limit custom image sizes to specific post types

Reported by: aaronholbrook Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Oftentimes I'll need a custom image size for featured images only for a specific post type and not for use in areas such as the blog or page post types.

This causes an undue strain on space usage for sites with frequent posting.

Ex. A blog site that puts out blog posts daily, but also has a directory section (CPT) with custom sizes for their featured image. Currently that means that all new blog posts now have additional image sizes created for them, which results in a large amount of wasted processing and space.

Change History (1)

comment:1 helen16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13372.

Note: See TracTickets for help on using tickets.