WordPress.org

Make WordPress Core

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#23112 closed defect (bug) (fixed)

Taxonomy meta box: choose_from_most_used not working if more than one none hierarchical taxonomy registered

Reported by: OttmarGobrecht Owned by: azaozz
Milestone: 3.5.1 Priority: normal
Severity: normal Version: 3.5
Component: Taxonomy Keywords: has-patch
Focuses: Cc:

Description

I registered two none hierarchical taxonomies on a custom post type. It works, when I am clicking the first time the choose_from_most_used link in one of the taxonomy meta boxes. The second click on the choose_from_most_used link in the other taxonomy meta box does not work. After reloading the page and testing vice versa it ist the same - the first click in one of the meta boxes is working, the other meta box is not working. May be a JavaScript-Error?

I tested on WordPress 3.5 (DE) and WordPress latest (2013-01-03).

I have attached my plugin code for testing.

Thanks

Attachments (2)

og-post-type-film.zip (4.5 KB) - added by OttmarGobrecht 18 months ago.
Plugin code with one post type and two taxonomies
23112.patch (569 bytes) - added by SergeyBiryukov 18 months ago.

Download all attachments as: .zip

Change History (7)

OttmarGobrecht18 months ago

Plugin code with one post type and two taxonomies

SergeyBiryukov18 months ago

comment:1 SergeyBiryukov18 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.5.1
  • Version changed from trunk to 3.5

Confirmed.

The regression is caused by the changes to post.js in [22268]. Those changes were only needed in earlier patches on #21324 to properly apply blur(), which was eventually removed.

23112.patch reverts that part of [22268].

comment:2 nacin18 months ago

  • Owner set to azaozz
  • Status changed from new to assigned

comment:3 azaozz18 months ago

Yes, no need for that change. Reverting it fixes toggling in multiple taxonomy postboxes.

comment:4 azaozz18 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 23277:

Taxonomy postbox: fix toggling with "Choose from the most used tags" when several postboxes are shown, props SergeyBiryukov, fixes #23112 for 3.5

comment:5 azaozz18 months ago

In 23278:

Taxonomy postbox: fix toggling with "Choose from the most used tags" when several postboxes are shown, props SergeyBiryukov, fixes #23112 for trunk

Note: See TracTickets for help on using tickets.