WordPress.org

Make WordPress Core

#23137 closed defect (bug) (duplicate)

xmlrpc wp.uploadFile

Reported by: lyfeway Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: XML-RPC Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

version: 3.5
File: wp-include/functions.php
Line: 1718
code: @fwrite( $ifp, $bits );
====================
if use xmlrpc to upload image, $bits is a encoded by base64.
right code: @fwrite( $ifp, base64_decode( $bits ) );

Change History (2)

comment:1 SergeyBiryukov15 months ago

  • Description modified (diff)
  • Keywords needs-refresh removed

comment:2 SergeyBiryukov15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20984.

Note: See TracTickets for help on using tickets.