WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#23138 closed defect (bug) (invalid)

TinyMCE not expanding to full height in Firefox

Reported by: GeraldS Owned by:
Milestone: Priority: low
Severity: minor Version: 3.5
Component: TinyMCE Keywords:
Focuses: Cc:

Description

In Firefox the TinyMCE does not use the full height of the edit area, only the first line is used. This is mostly apparent when you try to paste content via the context menu.

Clicking on the first line, where the cursor blinks, produces the expected context menu with the paste options.

Clicking in any other place below this line produces the context menu for "normal" DOM elements.

Opening the object inspector reveals that the edit area only covers the first line.

Tested with Firefox 17.0.1 and WordPress 3.5 (on Windows).

Attachments (1)

wp_tinymce_firefox_bug.png (42.5 KB) - added by GeraldS 5 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
5 years ago

Confirmed.

#2 @azaozz
5 years ago

  • Milestone Awaiting Review deleted
  • Priority changed from normal to low
  • Resolution set to invalid
  • Severity changed from normal to minor
  • Status changed from new to closed

This looks like a bug in Firefox' contenteditable rather than in TinyMCE. Used to work properly in older Firefox versions. Don't think there is anything we can do about it, needs fixing upstream.

Closing as "invalid" as there's no better resolution.

Note: See TracTickets for help on using tickets.