WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 9 months ago

#23141 closed defect (bug) (wontfix)

Add autocomplete="off" to all inputs that have a value

Reported by: alexvorn2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Administration Keywords:
Focuses: ui Cc:

Description (last modified by SergeyBiryukov)

On refresh in the browser - old data is filled in the inputs, instead of the actual data from the value attribute of the input.

to be more clear : http://www.screenr.com/p2K7

Change History (11)

comment:2 SergeyBiryukov16 months ago

  • Description modified (diff)

comment:3 follow-up: helen16 months ago

Doesn't this happen to all inputs everywhere across the web? What makes widgets.php so different?

comment:4 in reply to: ↑ 3 alexvorn216 months ago

The problem is that it's confusing sometimes when not the right text is displayed in the form input.
The input that have a value attribute I think should have an autocomplete=off atribute.

Replying to helen:

Doesn't this happen to all inputs everywhere across the web? What makes widgets.php so different?

Not everywhere, I tested on facebook, changing my name with a short one, and on a refresh the text has been filled with the original one. (But there is not a autocomplete="off" attr to the input).

comment:5 follow-up: helen16 months ago

I'm more interested in why you are singling out widgets.php when it can (and often does) happen anywhere you have a form input, including selects and others.

comment:6 in reply to: ↑ 5 alexvorn216 months ago

Replying to helen:

I'm more interested in why you are singling out widgets.php when it can (and often does) happen anywhere you have a form input, including selects and others.

Oh, then we can use everywhere not only in the widgets.php page... settings pages is a good idea too.

comment:7 alexvorn216 months ago

  • Component changed from Widgets to UI
  • Summary changed from Add autocomplete="off" to all inputs in the widgets.php page to Add autocomplete="off" to all inputs that have a value

comment:8 SergeyBiryukov16 months ago

  • Component changed from UI to Administration
  • Keywords ui-focus added

comment:9 helen16 months ago

Seems to me that we should generally retain default browser behavior because that's what informs user expectations, like keeping form data if you soft refresh or accidentally navigate back and forth. Now I'm curious as to why you find this to be a problem with WordPress as opposed to the web at large, because it really does happen everywhere. I deal with it regularly in development :)

comment:10 toscho16 months ago

  • Cc info@… added

Note, this is a browser specific issue (Firefox), other browsers use different auto-complete implementations. I guess you can turn it off in your browser.

comment:11 helen9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.