Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#23145 closed defect (bug) (duplicate)

Editing images only regenerates built in image sizes and not custom image sizes.

Reported by: hexpen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:


Steps to reproduce:

  1. Add image sizes using add_image_size (both cropped and uncropped perform the same).
  1. Add New under media and upload a picture. (At this point all image sizes are generated correctly)
  1. Edit newly uploaded image and perform an edit action such as crop or rotate (Edit -> Edit Image)
  1. Save edit changes and update the attachment.

Now only full size, large, medium, and thumbnail images are regenerated with the new edit and the custom image sizes are skipped.

Change History (1)

comment:1 @markoheijnen3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19889.

Note: See TracTickets for help on using tickets.