WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 11 months ago

#23166 closed defect (bug) (duplicate)

Post/Page slug collision

Reported by: AKTed Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Permalinks Keywords:
Focuses: Cc:

Description

If you create a page with the same slug as a post or vice versa, WordPress doesn't notice the slug collision. It doesn't append a -2 like it would if the collision were post/post or page/page. The post becomes inaccessible; the page effectively "owns" the slug.

I'm not sure if this is a bug, or just the way it's supposed to be.

Change History (6)

#1 @SergeyBiryukov
4 years ago

  • Component changed from Editor to Permalinks

#2 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13459.

#3 @saru1683
11 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 3.5 to 3.4.1

Sorry, a Version is 4.3.1

Last edited 11 months ago by saru1683 (previous) (diff)

#4 @helen
11 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed
  • Version changed from 3.4.1 to 3.5

Duplicate of #13459.

#5 follow-up: @saru1683
11 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 3.5 to 3.4.1

Yes @helen I already through out the ticket [ #13459] provided patch is only applicable on 2.9.2 while I am using latest Version 4.3.1.
I have searched several and no luck at all. If you want to reproduce the bug I will write a step of the process.
I don't understand why this is not fixed on Wordpress Core since 2.9.
I am not able to modify ticket for latest Version 4.3.1

Thank you.

#6 in reply to: ↑ 5 @helen
11 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to saru1683:

The version field is to indicate when a bug was reported, not when it will be fixed or where it's still reproducible. If you will note, #13459 is currently slated for 4.4. This is still a duplicate ticket. Please do not reopen it.

Note: See TracTickets for help on using tickets.