WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#23214 closed feature request (duplicate)

Registering a reserved taxonomy breaks permalinks in an awkward way

Reported by: Ahrengot Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Taxonomy Keywords:
Focuses: Cc:

Description

This is my first submission via track, so if I'm screwing things up, please let me know.

It seems that permalinks break in a really awkward way after you register a taxonomy using one of the 50+ reserved terms: http://codex.wordpress.org/Function_Reference/register_taxonomy#Reserved_Terms

For instance, I registered a taxonomy with the name year. After that, using the domain.com/%postname%/ permalink structure, all links returned the home page, except for 2nd level pages. For instance domain.com/page/subpage. Removing the year taxonomy and regenerating the .htaccess file fixed the issue.

As there are 50+ reserved taxonomy terms, I feel it's pretty easy to make this mistake. I propose an error or notice of sort if you try to register a reserved taxonomy term.

Change History (3)

#1 @Ahrengot
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23213.

#2 @helen
7 years ago

  • Milestone Awaiting Review deleted

#3 @SergeyBiryukov
7 years ago

  • Keywords needs-patch removed
Note: See TracTickets for help on using tickets.