WordPress.org

Make WordPress Core

#23222 closed defect (bug) (duplicate)

Title with % can break permalinks

Reported by: MikeHansenMe Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Permalinks Keywords:
Focuses: Cc:

Description

Permalinks try to use the title. But the title uses sanitize_title to clean it. This does not remove % and does not need to for the title but for the permalink it causes problems.

Steps to reproduce

  • set up permalinks (anything with %postname%)
  • create a new post/page with the title %90
  • click "view page"
  • check the url

the result is example.com/�/

Another problem without js

  • disable js and add new page
  • use %91 as the title
  • publish the post
  • click view page

the result is example.com/%91/

Related or Similar tickets : #6072, #5305

Attachments (1)

new-permalink.diff (2.4 KB) - added by MikeHansenMe 15 months ago.

Download all attachments as: .zip

Change History (2)

comment:1 SergeyBiryukov15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3329.

Note: See TracTickets for help on using tickets.